Jump to content
Corsair Community

H115i, fans running at 100%, iCue and link doesn't recognize the pump


Recommended Posts

Hi all,


I have a problem with my new H115I.

Yesterday I installed the H115i on my Ryzen 7 2700X, on a clean windows 10 64-bit system.


I installed Corsair Link and iCue and all working fine. Then I update the firmware from the Lightning Node Pro, Vengeance Pro and the H115i. After this, the H115i are not working completey fine.


iCue and Link doesn't recognize the pump. I don't see it and can not control rgb or the pump/fans. I can see the pump in the device manager from windows 10.


The rgb from the pump shows only a purple color and the fans rgb are off. Futhermore the fans are running now at 100%.


Can any one help with this problem?


Thanks a lot.



Link to comment
Share on other sites

  • 4 months later...
any solution on this? my H115i Platinum shows in USBDeview but NOT iCUE. I have done MULTIPLE complete uninstalls of iCUE, tried multiple versions of iCUE, deleted every other RGB program, tried two different USB headers, made sure Windows was fully updated, IDK what else to do, this thing is bricked!
Link to comment
Share on other sites

  • 3 months later...
  • Create New...