Jump to content
Corsair Community

M65 RGB Elite


bLuNt_wAcO
 Share

Recommended Posts

Good day all,

Brand new M65 RGB Elite (1 day old) and having issue with mouse all of a sudden stops working. Lights on mouse are still on and changing colors but mouse cursor on screen doesn't move!!

 

Windows Surface Book 2, WIN10

Anyone having same issue? Is the mouse defective?

 

Thank you.

Link to comment
Share on other sites

Does iCUE detect the mouse? If so try reflashing the firmware.

If iCUE doesnt detect the mouse, unplug the mouse. Hold down the left and right click while plugging it in. iCUE should prompt you to update the mouse firmware.

 

If that still doesnt work PM me your email. I will send you the steps and files for a hard firmware reset.

Link to comment
Share on other sites

Does iCUE detect the mouse? If so try reflashing the firmware.

If iCUE doesnt detect the mouse, unplug the mouse. Hold down the left and right click while plugging it in. iCUE should prompt you to update the mouse firmware.

 

If that still doesnt work PM me your email. I will send you the steps and files for a hard firmware reset.

 

Thanks for the reply. I just re-flashed the firmware. I will test and report back to you.

Thanks.

Link to comment
Share on other sites

Does iCUE detect the mouse? If so try reflashing the firmware.

If iCUE doesnt detect the mouse, unplug the mouse. Hold down the left and right click while plugging it in. iCUE should prompt you to update the mouse firmware.

 

If that still doesnt work PM me your email. I will send you the steps and files for a hard firmware reset.

 

Just to let you know, since yesterday after forcing the firmware update I have no more disconnects/issues. Hopefully this would be it.

 

Thank you for your help.

Link to comment
Share on other sites

 Share

×
×
  • Create New...