Jump to content
Corsair Community

[Solved] Corsair iCUE not detecting Lighting Node Pro


MelaciousMel
 Share

Recommended Posts

Recently I decided to add RGB elements to my custom build and ran into an issue with the iCUE control software. I installed the LL140 dual RGB fans (w/ Lighting Node Pro) to accompany my G.Skill TridentZ RGB Ram and Corsair Void Pro Headset, but for some reason iCUE was only detecting my Corsair Voids and not the Node Pro.

 

... I can't tell you how long I tried to fix this issue myself; what's even worse was the answer was so simple.

 

Here's the Fix: During installation of the lighting node pro, it will tell you to install the USB cord directly into one of your USB1,2,etc slots on your mobo. If you find that iCUE is not detecting your Node Pro, simply unplug and replug into a different USB slot. That's...Literally...it...

Example: For me, I had it plugged into the USB1 slot, and had to move it to the USB2 slot.

 

Special thanks to Corsair Customer service for giving me the clarity to try this fix. Hope it helps some of you out there with a similar problem.

 

Happy Building!

Link to comment
Share on other sites

  • 10 months later...
I made sure the SATA power connections are working and that the USB ports are both working and no help whatsoever. I even used a different lighting node core to no avail. I really tried everything from reinstalling iCue 3 times and even a fresh windows install. I love corsair but iCue has always let me down. Do I really have to buy a new motherboard and pray corsair iCue will play nicer with this one? I see this problem posted on multiple threads yet there is no fix and this one is marked as a fix but it really isn't.
Link to comment
Share on other sites

A) Can you check USBDeView to see if the LNC shows up there? Download USBDeView from https://www.nirsoft.net/utils/usb_devices_view.html. If it's not there, it's not connected via USB and iCUE won't see it.

 

B) If it's not connected via USB, there are several things to try. First, make sure that your chipset drivers are up to date. Windows may autodetect - don't just rely on that. Get the drivers from your motherboard manufacturer. Next, disable Fast Boot in your BIOS and make sure that XHCI Handoff is enabled. Also, disable Windows Fast Startup (https://www.windowscentral.com/how-disable-windows-10-fast-startup). Both of these do stuff with USB detection and can cause issues.

Link to comment
Share on other sites

Hey DevBiker thanks for the help unfortunately I was unable to fix the problem and I believe it to be an error for older ASUS motherboard BIOS, even though I have the current update BIOS and Drivers the XHCI Standoff option was removed form the BIOS and the only way I got the USB 2.0 slots to actually function was when the motherboard would not post (lol). So it was nice seeing the fans rgb lights actually turn on, except the computer wouldn't post when they did. I've tried every other option in the BIOS to no avail. Thank you sorry I couldn't find a fix but I do not believe this to be a Corsair problem.
Link to comment
Share on other sites

  • 6 months later...
I have the exact same issue updated my controller I have the one you can plug 6 RGB wires into the controller it randomly stopped working won't even recognize on my ique but my commander pro will. Tried resetting it, deleted corsair 5 times and re installed, unplugged USB and moved it all over the board even into my commander. Unplugged Sata and plugged back into a different connector with 0 luck fans stuck on rainbow. I loved the corsair fans but with this issue I'm getting irritated, I have corsair AIO corsair vengeance pro memory and corsair STRAFE m2 keyboard and they all light up just fine. can control the fan speed with my commander for my fans on the AIO but fans stuck in rainbow. The only thing I have not tried is removing 1 fan led connector and plugging it into the commander to see if it is software related or node related. Frustrates the living crap out of me because I'm looking to go full custom loop and I'm starting to rule out corsair.
Link to comment
Share on other sites

  • 4 months later...
 Share

×
×
  • Create New...