Jump to content
Corsair Community


Recommended Posts

Hey guys. So for the past two days I've been having this really ANNOYING issue with my mouse, and it seemed to happened right after I updated to the latest Icue (3.12).




I wanted to post here to share my findings, because I think I've found out some possible causes, and solutions.


So, let me tell you what I've done to try and correct this issue, as well as the things I've taken into consideration... When my mouse began micro-stuttering, I confirmed that it was indeed *only* happening to my cursor. My CPU wasn't being maxed out, my SSD wasn't being thrashed, nor was my RAM leaking.


I disabled and swapped ICUE profiles, disabled RGB effects (in case somehow RGB was causing some of conflict) I went back to earlier updates, and I even tried out every available USB port on my computer. I checked each, and every driver, uninstalled, reinstalled, including ICUE.


But, one thing seemed to work...


Solution 1a


So, at my wits end, I decided to check for a Window's update, and lo-and-behold, there was one available since Feburary 16th 2019 (couple days ago as of writing). This update in particular addressed an Intel graphics driver that was rolled out for specific OEMs (unfortunately I'm unsure which); this driver accidentally enabled features that aren't supported in Windows 10. I figured that driver conflicts at any level might be causing my mouse issue... Thankfully, it seems this was the case - but I can't say for sure. If not, the second solution I also tried at the same time might have been the solution.


Solution 1b


I also had recently uninstalled all of my USB drivers (hubs, as well as corsair drivers/mouse), and restarted my computer.


At this point, as I was downloading the update I opened CMD.exe in administrator mode (very important), and typed in "sfc /scannow". There were some corruptions & duplicates in my systems from swapping/installing stuff over the years, so it fixed a lot of things. Note: running this command will revert any changes you made to Window's system files, and Window's DLL files - so if you made any modifications or alterations, consider creating back ups. In my case, I had to reinstall Classic Shell, a windows 8 start menu modification.


Furthermore, if you're hesitant of using this feature you can type in "sfc /verifyonly" and this will check your files, but not change anything.


After doing this, and installing the update, I restarted my machine and found that my mouse wasn't stuttering anymore (and hasn't for 12+ hours). I think the issue is gone for good!!


Other solutions if the above doesn't work... Any one of these solutions, perhaps coupled with the ones above might end up working for you.


  • Go to Device Manager, and right click on all control devices under Human Device Interfaces & Universal Serial Bus controllers, then select properties > Power Management, and turn off "Allow the computer to turn off this device to save power".
  • Try disabling/uninstalling ICUE and using your mouse without this service, ICUE may be the root cause. Who knows, maybe the ICUE driver changed something in the system which the sfc scan fixed. **Note, if you uninstall ICUE, use CCleaner to remove any left over registry files.
  • Go to Power Management, and try out the "Favor High Performance" plan. Click change settings > change advanced settings, and then go to USB settings, and then to "USB selective suspend setting" and disable it (if not disabled already).
  • Navigate to device manager again, and uninstall the drivers for your mouse, keyboard, and "Corsair composite virtual device". Then open up "Add/Remove programs", find ICUE, and repair it. Then restart your computer.
  • In device manager (again), try systematically removing all USB drivers in general, and then restarting your computer to force a fresh install.
  • Try disabling RGB features of your Corsair mouse, and keyboard. Even try changing the colors themselves. **Note: I was getting an odd error in ICUE's log, and I noticed when I changed my DPI (it shows color for each DPI setting on my mouse), it flickered and skipped a color. When I changed the color that was flickering from blue to red, it stopped. Maybe it's a RGB issue?
  • Try shutting down Realtek (sound package that came with my ASUS ROG mb if you have it). May be a sound driver issue.
  • Furthermore, try shutting down/disabling other software that controls RGB features on other hardware, such as EVGA, Aura, and HUE+.
    **NOTE: if you're uninstalling drivers, try and clean up residual registry entries and temporary files related to software in App Data & Local ( Local Disk (C:) > Users > (Your User Name) > App Data > Local & Roaming).


I hope this helps guys. I really does. This issue was driving me INSANE for 3 days. Now I'm back to gamin' (finally).

Edited by jakerling
re-formatted some areas, and fixed some grammar mistakes. If anything bothers you, don't be afraid to point it out!
Link to comment
Share on other sites

  • Create New...