Jump to content
Corsair Community

corsair vengeance pro RGB light freezes


xaoyama
 Share

Recommended Posts

Hi everyone , recently i purchase a 16gb kit of the above mentioned ram in white , it's a pack of 2 8gb sticks rated at 2666mhz. The issue is that one of the sticks gets frozen in a particular color or effect such as a rainbow or static. the only way to "fix" it is when i fully unplug my PSU and re boot my pc then I can change the lighting once before it freezes again. This is pretty annoying and I tried going directly to corsair customer support but I keep getting an error while trying to log in. any help is appreciated. thank you

 

 

 

 

 

 

this is the error

https://gyazo.com/1cda6108781be2f69326ac2ffdb35c3e

Edited by xaoyama
Link to comment
Share on other sites

It could be because of different models.

 

It could but I highly doubt it, I bought a 16gb kit and another one after 2 months to use in the system. In total I am using 4 sticks 8GB each but they freeze when launching some games. I suspect the Asus Aura software and Corsair's iCue software may be incompatible during some actions (for my situation). As I am typing this Asus Aura isn't even working on my board (the mobo and gpu are in default rgb settings) and corsair ram is frozen after trying to open Aura Sync but nothing happening. It is quite frustrating especially spending the extra money just to get the RGB effects.

Link to comment
Share on other sites

It could but I highly doubt it, I bought a 16gb kit and another one after 2 months to use in the system. In total I am using 4 sticks 8GB each but they freeze when launching some games. I suspect the Asus Aura software and Corsair's iCue software may be incompatible during some actions (for my situation). As I am typing this Asus Aura isn't even working on my board (the mobo and gpu are in default rgb settings) and corsair ram is frozen after trying to open Aura Sync but nothing happening. It is quite frustrating especially spending the extra money just to get the RGB effects.

 

 

Same, I paid just for the whole light on the pro and didn't want to go to trident z, i deleted ALL other RGB apps and no luck

Link to comment
Share on other sites

  • Corsair Employees

Hello xaoyama,

 

 

Sorry to hear that you're having an issue. Unfortunately mixing kits can cause many issues from lighting to stability issues. I would recommend running the force firmware update in iCUE under settings on each kit by itself in the system.

 

I would try to replicate the issue per kit before trying anything else. Assuming everything works fine then you could try them both in the system at the same time.

Link to comment
Share on other sites

Ive tried submitting a ticket but when ever i try logging in and going the support portal it gives me an error, i mentioned it in my original post. Trmw ill try to see if the problem persists while having only one kit installed. thanks for the help so far Mr.Corsair Rick
Link to comment
Share on other sites

 Share

×
×
  • Create New...