Jump to content
Corsair Community

iCUE software affect refresh rate


mascarpwn
 Share

Recommended Posts

Does anyone have a solution for the iCUE software making the refresh rate jump up and down whenever it's on the foreground?

 

This has become ridiculous and makes me never want to buy Corsair products ever again.

 

The software is up to date

The firmwares are up to date.

 

I have a Corsair mouse, keyboard and headset and an Asus Gsync monitor which shows the refresh rate in the top right corner. Whenever iCUE is on the foreground, I notive the computer lagging, then I saw my refresh rate jumping from 165 to extreme lows, up and down until I stop press on the top right cross. If, for some reason iCUE is open during a game, the whole game laggs (for obvious reasons).

 

How is it possible that a simple piece of software can affect the refresh rate of our screens and when will there finally be a solution?

Link to comment
Share on other sites

Presumably you mean your frame rate changes, rather than the screen’s refresh rate setting is being altered. The OS sees the dashboard window as a graphics application and it is using GPU resources to render all those little graphs. You likely want to change your Gsync setting to full screen only so it stops tripping over it on the desktop. If you are looking for maximum GPU performance in full screen mode, close the iCUE app. It will still track the data in background, but it will no longer use GPU power.
Link to comment
Share on other sites

Presumably you mean your frame rate changes, rather than the screen’s refresh rate setting is being altered. The OS sees the dashboard window as a graphics application and it is using GPU resources to render all those little graphs. You likely want to change your Gsync setting to full screen only so it stops tripping over it on the desktop. If you are looking for maximum GPU performance in full screen mode, close the iCUE app. It will still track the data in background, but it will no longer use GPU power.

 

So, graphically advance games stick to ~140 fps at max settings, but iCUE software is so demanding it makes my frame rate and thus refresh rate drop below 30.

 

Well, this definitely is the last Corsair product I'll even buy.

Link to comment
Share on other sites

Presumably you mean your frame rate changes, rather than the screen’s refresh rate setting is being altered. The OS sees the dashboard window as a graphics application and it is using GPU resources to render all those little graphs. You likely want to change your Gsync setting to full screen only so it stops tripping over it on the desktop. If you are looking for maximum GPU performance in full screen mode, close the iCUE app. It will still track the data in background, but it will no longer use GPU power.

 

So, graphically advance games stick to ~140 fps at max settings, but iCUE software is so demanding it makes my frame rate and thus refresh rate drop below 30.

 

Well, this definitely is the last Corsair product I'll even buy.

Link to comment
Share on other sites

So, graphically advance games stick to ~140 fps at max settings, but iCUE software is so demanding it makes my frame rate and thus refresh rate drop below 30.

 

You have something else going on. No one would use the product if your supposition was correct.

Link to comment
Share on other sites

You have something else going on. No one would use the product if your supposition was correct.

 

Really?

 

 

http://forum.corsair.com/forums/showthread.php?t=175559

 

https://us.forums.blizzard.com/en/overwatch/t/possible-compatibility-issue-with-icue-corsair-with-latest-patch/172722/7

 

Corsair recommends a "rollback" to older drivers/firmware.

 

Yeah, no more Corsair for me. Thanks anyway lads.

Link to comment
Share on other sites

Three random people with disparate issues, none of them detail their hardware or explain any troubleshooting steps. Just three people who have some sort of problem and think it must be the program. You're the fourth. The other 50,000 of us are just lucky I guess.

 

You seem determined to quit and with no intent of troubleshooting or trying to work out what's happening. I don't feel any pressing need to stop you.

Link to comment
Share on other sites

Same thing happens with my system if I have GSYNC enabled for both full and windowed screen applications.

 

Minor annoyance - yes, I just live with it. Lol.

 

<--- Specs

R7 1700x

GTX 1080

Acer Pred XB271HU

 

Try the original suggestion of changing Gsync to full screen only. If you actually play in windowed mode, then definitely X-out iCUE to the tray before loading up. I would close it to the tray regardless. You can’t see it when playing. I have a Gsync panel as well and have never seen this. I do occasionally run into some glitchy behavior with it open in the background, but nothing like a crippled frame rate. The Windows focus assist settings might play a part as well if full screen.

Link to comment
Share on other sites

Try the original suggestion of changing Gsync to full screen only. If you actually play in windowed mode, then definitely X-out iCUE to the tray before loading up. I would close it to the tray regardless. You can’t see it when playing. I have a Gsync panel as well and have never seen this. I do occasionally run into some glitchy behavior with it open in the background, but nothing like a crippled frame rate. The Windows focus assist settings might play a part as well if full screen.

 

Yup that's what I've been doing, it was just a minor annoyance. I just set profiles and leave it running in the background on the tray. Not a big problem for me.

 

And yea I do have focus assist turned off.

Link to comment
Share on other sites

The only other thing I can think of is if users have some custom override settings in the Nvidia Control Panel (MFAA On, Super-sampling, Forced Anisotropic or AA, etc.) applied to the global setting and this is somehow being forced upon the iCUE window. That is definitely speculative.
Link to comment
Share on other sites

  • 2 months later...
The only other thing I can think of is if users have some custom override settings in the Nvidia Control Panel (MFAA On, Super-sampling, Forced Anisotropic or AA, etc.) applied to the global setting and this is somehow being forced upon the iCUE window. That is definitely speculative.

 

This was the issue for me. I had previously modified some settings in the Nvidia control panel under "Manage 3D settings". The issue was only occurring with G sync enabled. I just restored all settings in Manage 3D settings and the issue stopped.

Link to comment
Share on other sites

  • 8 months later...
 Share

×
×
  • Create New...