Jump to content
Corsair Community

Vengeance pro stopped working after iCue launch


Baronding
 Share

Recommended Posts

He guys,

 

I hope maybe one of you could help me out here.

I bought my vengeance pro dims (2x 8gb 3200mhz) about 2 months ago.

When I build the pc the leds started to light up in a rainbow spiral manner.

Everything looked good here.

 

But then I installed iCue to manage the rgb's. Once I opened iCue the leds stopped and no devices were detected.

 

Tried firmware updates, xmp profiles disabled, other slots in mobo, nothing worked. Then I got new ram sticks from my supplier under warranty.

I installed them, exactly the same thing happened here.

 

I have no clue whats going wrong here.

 

mobo: Aorus x470 ultra gaming

ryzen 7 1700

 

Hope someone has a fix for this.

 

cheers,

 

Aaron

Link to comment
Share on other sites

  • Corsair Employees

Hello Baronding,

 

Sorry to hear that you're experiencing an issue with the memory. I would suggest submitting a ticket at support.corsair.com about this. I'm sure our Technical Support team will be able to help you get the memory up and running!

Link to comment
Share on other sites

Hello Rick,

 

Ive already done that when I encountered the problem with the first pair.

They eventually said it should be the ram sticks so they offered me a refund.

This was through the corsair support channel. I got my refund / swap from the supplier.

 

I guess they didnt know what to do either?

Link to comment
Share on other sites

Hi,

 

i had this Problems for 6 Month

 

today I solve the Problem with an BIOS Flashback of my Motherboard.

 

BIOS ROG-STRIX-X470-F-GAMING-ASUS-4207 - dont work

BIOS ROG-STRIX-X470-F-GAMING-ASUS-4204 - dont work

 

BIOS ROG-STRIX-X470-F-GAMING-ASUS-4024 - and all works fine

Icue found my RAM

 

Hope this will help you

 

Cheers Holle

Link to comment
Share on other sites

 Share

×
×
  • Create New...