Jump to content
Corsair Community

iCue, RAM RGB and Sleep


Lord Polymath
 Share

Recommended Posts

I don't want the RGB on my ram to stay on when the computer is asleep. I can accomplish this by checking the "Enable full software control" box in iCue. However, doing so causes the Corsair.Service.CpuIDRemote process to use 10% of my CPU, which is unacceptable. With the software control option unchecked, that process only uses .5% or less but the RAM lights stay on when the computer is asleep.

Any ideas?

 

Corsair K70 RGB

Corsair Vengeance Pro RGB 2x8gb

ASRock x390 Phantom Gaming 6

i5 9600k

Windows 10 Pro x64

Link to comment
Share on other sites

Hey! I have the same problem and I just joined the Corsair forums to reply to this thread. I was playing Battlefield on my new system when I noticed Corasir.Service.CpuIdRemote was using 16% of my CPU!! That's insane!

 

I don't want the RGB on my ram to stay on when the computer is asleep. I can accomplish this by checking the "Enable full software control" box in iCue.

 

I enabled the same setting you did, which gave me more live control over the lights. Presumably by enabling this setting, the computer talks directly to RAM? I actually don't even know how interfacing with the RAM DIMM itself is even possible (no USB interface?), but by observing the lag it takes for a command to show on the RAM strips when full control is off tells me that the RAM is running on its own and possibly periodically checking if something has changed. This probably explains why the RAM maintains it color while the computer is off and can do a rainbow effect when in the BIOS.

 

This is only my assumption, but I'm thinking the RAM is checking for changes a lot faster with full software control enabled, since moving a brightness slider in iCUE translates to a very fast brightness change on the DIMMs.

 

There must be a better way...

 

Because I'm having the same issues. RAM is too bright when computer is off & trying to sleep. For now I'm just turning that setting off and setting the brightness to something barrable like 50% Hopefully they fix this sometime in the future.

Link to comment
Share on other sites

 Share

×
×
  • Create New...