Jump to content
Corsair Community

K95 Non-RGB Firmware Update Issue


AlexKVideos1
 Share

Recommended Posts

I am using the older firmware, and driver as I decided to go for the Non-RGB (just white lights) version of the K95, what a big mistake.

 

The firmware update never worked for me. I would click on the version number, 1.15v, yet hitting OK would do nothing. It always gave me this error after hitting cancel:

0kj0xod.png

Even if I tried to update it, it still fails. I've tried as much as I could, but yet I still can't figure out what the issue is. Like I used the BIOS switch in the back, uninstalled drivers, reinstalled them, used Windows compatibility mode, but no luck.

 

All my specs if you need it:

OS: Windows 10 Pro

Storage: 1 TB Samsung 850 EVO SSD

4 TB WD Black

CPU: Intel Core i7 4790K

GPU: (MSI) NVIDIA Geforce GTX 980

PSU: Corsair RM850

Motherboard: MSI Z97A Gaming 6

Ram: Corsair Vengeance 16 GB DDR3

Optical Drive: LG WH16NS40

Monitor: ASUS VG248QE 24in 144Hz 1080p

Keyboard: Cosair Gaming K95 (Non-RGB)

Mouse: Logitech G502

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
 Share

×
×
  • Create New...