Jump to content
Corsair Community

Corsair service CPU Usage High


heaven93tv
 Share

Recommended Posts

Hello there everyone ,

I'm here looking for some help if you don't mind :sigh!:

So i'm kind of nervous because the corsair service cpuIDRemote ( check the picture attached please ) is using a lot of my cpu and i've been wondering if this is how it should run or there's some kind of bug !

Is there any way to disable it ? on the services panel i only find one and only Corsair Service , so i can not turn off this specific one ! Thank you.

attachment.php?attachmentid=34976&stc=1&d=1547743678

serv.thumb.png.6f5ddc62c2696924c59af62494b084a8.png

Link to comment
Share on other sites

  • 2 weeks later...
Yes, it's frustrating, I've disabled software control on my Vengeance Pro RGB due to high cpu usage. In general I find the software buggy, my MM800 and ST100 randomly stop running profiles, when running benchmarks my fan profiles go wonky and it seems to get worse with each update. It's annoying when you invest alot in a brand and are let down by poor software!
Link to comment
Share on other sites

The issue when running benchmarks is thread starvation. The complex effects that iCUE provides are run in software - when you are running benchmarks, the CPU is consumed by the benchmark (which is the point of the benchmark, right?). You don't expect, say, Firefox to run real snappy when you are running a benchmark, do you?
Link to comment
Share on other sites

I have this very same issue,

 

but I DO NOT have a ram with lights, the ram is corsair but no lights on it, the only corsair device the icue is managing is k70lux non rgb keyboard.

 

I have to manually suspend the service every reboot because it uses 5% of cpu every 5 seconds.

 

Got any suggestion for me? Seeing as I can't turn lights on ram off.

Link to comment
Share on other sites

  • 9 months later...

After messing around with it a little if found a simple solution:

1-download corsairs i cue latest version

2- download the rgb memory plugin

3-restart cpu

4-open i cue

5- click on the ram/memory

6-once clicked go to the setting and turn the brightness level to 0

7-close the program

8-go to control panel and uninstall i cue and rgb plugin in

and hopefully no more light on the ram stick!

Link to comment
Share on other sites

 Share

×
×
  • Create New...