Jump to content
Corsair Community

Scimitar pro rgb - undesirable rapid fire without icue


dired
 Share

Recommended Posts

I have mapped numpad buttons to the scimitar's side buttons ("Keypad_0"-"Keypad_9") via the Remap Keystroke action.

 

When the icue software is running, I press e.g. the first sidebutton and I get one "1": 1

(when I hold the sidebutton for a bit longer, the key starts repeating itself like it is set in the windows keyboard settings)

When icue is not running - when the mouse is in "standalone" mode, also e.g. when I use it on a foreign computer - I press the sidebutton, and the 1 immediately starts repeating itself (I click the button here for just half a second: 1111111111111111111).

 

It is like it is rapid-firing actively, without icue running it is not possible to get a single one as it is repeating the keystroke so fast (even faster than with just holding down the key on the keyboard).

 

Is this a know problem? What can I do about it to have the mouse not rapid-firing without icue running?

 

Best regards and thanks in advance!

Edited by dired
Link to comment
Share on other sites

sorry for all the fuzz, i was a bit stressed because of this.

 

Solution: don't use the function remap-keystroke but remap-numeric keypad.

then i get consistent single clicks instead of rapid-firing the numpad-key-values.

 

What remains is the question why the function remap-keystroke rapid-fires automatically and there is no setting to turn it off?

I believe that's not documented but I could be wrong. Anyhow I'm fine now :)

 

Greets

Edited by dired
Link to comment
Share on other sites

 Share

×
×
  • Create New...