Jump to content
Corsair Community

iCUE Performance Issues?


g0mikese
 Share

Recommended Posts

I've just finished putting together a new PC for the first time in tooooooo long. My Old PC Was an Intel Core i7.... wait for it..... 920. Yes, 920. You can see I needed an upgrade and I could finally afford one so I went for it!

 

Before I upgraded the rest of my PC I picked up a Corsair K95 RGB Platinum and an M65 Pro RGB. I really like both and even on my old PC had no issues with the iCUE software (I was using release 3.4.95). Because I already had iCUE devices and liked them, and I've always like Corsair for RAM as well I decided I may as well get other Corsair RGB products that also use iCUE for the new PC.

 

I've no completed the build (details to follow) and on a brnad new Windows install I'm seeing weird behavior in Windows. Specifically with the Windows Desktop and Explorer.exe in it's various forms.

 

I specifically notice that when dragging a selection around icons on the desktop to re-arrange things the action is very very laggy. Pressing the up ^ icon in the system tray to show hidden items is also significantly delayed, and even launching task manager takes longer than it should. Turning off iCUE causes the responsiveness to jump right up to where I'd expect it however.

 

I've tried turning off/disabling other loaded programs besides iCUE and it doesn't appear to be an issue with iCUE conflicting with one of them that I'm seeing. I'll provide a list of those below as well just in case though. I get the issue even with nothing else launched except iCUE.

 

On my new PC I have tried iCue versions 3.4.95, 3.10.125, and 3.11.114

 

Hardware:

  • ASRock Taichi Ultimate z390
    • Latest Firmware
    • Has it's own RGB system but I do not have it's software running at the same time

    [*]Intel Core i7-9700K

    [*] Corsair H150i Pro

    • Replaced stock Corsair ML Fans for Corsair ML RGB fans

    [*]32GB Corsair Vengeance RGB Pro DDR4 3200 RAM

    [*]EVGA GeForce 2080 XC Ultra Gaming RGB

    [*]3 additional Corsair 120mm ML RGB Fans

    [*]Corsair RMX White Series RM850x PSU

    [*]Samsung 970 Pro 512GB NVMe M.2 SSD (boot volume)

    [*]WD Blue 2TB SATA3 M.2 SSD (game storage)

    [*]Several 7200RPM HDDs (long term storage)

    [*]Corsair Commander Pro Fan Controller

 

Corsair RGB Lighting wiring:

  • USB on MB
    • Commander Pro Fan Controller
      • Channel 1
        • Corsair RGB Fan Hub
          • 3 ML RGB fans mounted to the case for intake

        [*]Channel 2

        • Corsair RGB Fan Hub
          • 3 ML RGB fans mounted to the H150i Radiator (not using the fans provided with this)

      [*]USB port on fan controller

      • Corsair H150i USB Cable for Water Block

    [*]Corsair Vengeance RGB Ram in all 4 slots

    [*]EVGA Geforce Card has RGB as well

    • I haven't even bothered with it as I like it's Blue and have been dealing with iCUE issues.

    [*]ASRock Also does RGB, this software is installed but it's effectively Hardware profiles only. Doesn't run actively in the OS.

 

Programs I run on Boot:

  • Discord
  • Directory Opus
  • Stardock Fences
  • Stardock Groupy
  • Plex Media Server
  • Display Fusion
  • iCue
  • Screens Connect
  • Steam
  • TightVNC Server
  • Snagit
  • The usual things like Realtek HD Audio drivers, intel drivers, etc

A few of those interact with Explorer.exe in strange ways (hell Directory Opus replaces it as a file browser), but I've tried disabling all of these and still see the issues

 

Thoughts?

Link to comment
Share on other sites

  • 8 months later...

I have exactly the same problem, i think it may have to do with ASRock, since I do have a ASRock Z390 Phantom Gaming 9. On my old system with an ASUS Mainboard, everything is OK. Same patch level, same device drivers.

 

On my ASRock I do have performance issues, on my ASUS I don't.

 

I do have three Corsair Components:

 

- K95 RGB Platinum

- Sabre RGB

- RM650i

 

If i do start the iCue Software my explorer gets really slow. Simply opening the explorer takes up to 5 seconds, without iCue .5 or less seconds.

 

Did you find any fix?

 

I tried every other iCue Version since 3.14.xxx

Edited by esskaa
Update
Link to comment
Share on other sites

 Share

×
×
  • Create New...