Jump to content
Corsair Community

iCUE not detecting my vengeance rgb pro ram after bios update


kyan31
 Share

Recommended Posts

Hi guys,

 

As the title says, after I updated my motherboard bios, my iCUE no longer detects my Corsair Vengeance RGB Pro RAM (3200Mhz). I have tried repairing the iCUE software, fully uninstalling, rebooting, then reinstalling, and I have also reseated the RAM sticks and then repeated the same steps. No luck getting them detected. Any reason why this would happen? I doubt the bios update would intentionally disable the feature so im guessing the update has caused iCUE to no longer recognise the RAM.

 

My motherboard is the ASUS X470 PRIME PRO, and I use Windows 10 with the latest iCUE software of course. I have the RAM in the recommended DIMM slots for this board, slot 2 and 4. My iCUE worked fine prior to the bios update. Would appreciate any help, thank you.

Link to comment
Share on other sites

Thanks for the reply, and yeah I figured and I think I have found the root cause of which update broke it. It seems update 4204 (For the ASUS X470 Prime Pro) introduces a feature called AGESA 1006 which is an updated memory/DRAM update, and this is the exact update that breaks vengeance ram. I tried the exact bios update (4204) which introduces AGESA, as suspected vengeance ram is not recognised. As soon as I downgraded to the previous update (so the update just before the AGESA update, 4024) the ram rgb started working again. This means AGESA 1006 is likely the culprit. Hope Corsair can look into this.
Link to comment
Share on other sites

 Share

×
×
  • Create New...