Jump to content
Corsair Community

iCUE prevents i9 9900K turbo boost


hrngrd
 Share

Recommended Posts

Hi,

 

I'm experiencing this wierd issue on my freshly installed PC:

When iCUE is running, none of my i9 9900K's 8 cores will ever boost above 4700Mhz, but immediately after closing iCUE the cores start reaching their full boost potential of 5000mhz. Starting iCUE again drops the max boost to 4700Mhz again.

 

Cinebench scores are affected both on single cores and full CPU scores.

 

My case fans (3xML140 RGB) are connected to Corsair commander. The AIO fans are connected to the H115i pump. (both RGB and fan headers)

 

Cinebench R15 without iCUE running

Single Core Score: 213

Full CPU Score: 2027

 

Cinebench R15 with iCUE running:

Single Core Score: 199

Full CPU Score: 1864

 

Any ideas?

 

Software:

Windows 10 v17763

iCUE v3.10.125

CPUID HWMonitor v1.38.0

 

Specs:

 

i9 9900K @Stock speed

4x8GB G.Skill TridentZ RGB @3200Mhz CL16

Gigabyte Z390 Aorus Master (BIOS F8B)

Gigabyte Geforce RTX 2080 Ti Xtreme

Samsung 970 EVO 1TB NVME M.2

Corsair HX850x (2018) PSU

Corsair Hydro Series 115i RGB Platinum with 2x Corsair ML140 RGB fans (FW v.1.00.33)

3x Corsair ML140 RGB Fans

Corsair Commander (FW v.0.8.210)

Fractal Design Define S2

Asus Swift PG279Q 27" G-Sync Monitor

Corsair K70 RGB keyboard

Mionix Castor Mouse

Link to comment
Share on other sites

Thank you for providing a lot of information. Do you have any custom settings in the UEFI or are we talking everything stock?

 

I have a 9900K and a Z370 Gaming 7. I am curious if I can replicate the issue. I think I recall not seeing my CPU boost to 5Ghz stock, though I OC'ed it to 5Ghz in the UEFI. No AVX Offset.

 

My first thought is there might be AVX offset of -3, though I don't think iCUE would use AVX. I don't use Cinebench to stress test, though from what little I just Googled, Cinebench doesn't look like it leverages AVX.

 

Lastly I can confirm closing as many tools and applications appears to boost your score in cinebench.

Link to comment
Share on other sites

BIOS settings are completely clean "Load optimized defaults" and stock except using XMP settings on the memory, no AVX offsets, and Multi-Core Enhancements remain at the default "Auto" (not enabled, which boosts all cores to 5Ghz more or less permanently)
Link to comment
Share on other sites

  • 1 month later...

So I am experiencing this as well. I have an AVX offset of -3 set but...iCUE is dropping anywhere from 150-200Mhz off my cpu clock when it is running.

 

All speedsteps and C states disabled in bios, no power saving features enabled.

 

Anyone looking into this? iCUE doesn't use AVX instructions does it?.....lol....?

 

i9 9900K

Z390 Aorus Master F8e bios

Edited by chr0n1c
Link to comment
Share on other sites

CPUZ & Windows Task Manager & Hardware info all read this info.

 

I did more testing last night and was able to reproduce it over and over and over again under the following conditions.

 

1) AVX offset set to 1, 2, 3, 4, etc.

2) CPU Multi Locked @ 50. System been tested prime stable 6 hours at this frequency, custom watercooled.

3) All C States, Speedstep, Power saving, and any other such feature in bios and windows disabled.

 

I start iCue and open CPUZ & Windows Task Manager & Hardware info, individually and all together. The readings are consistently 100-150-200-300Mhz CPU clock fluctuation.

 

I exit out of everything open CPUZ & Windows Task Manager & Hardware info, individually and all together.....CPU clock steady at 5Ghz as it should be.

 

I made sure I had every other application closed that I possibly could.

 

I went back into bios and set AVX offset to 0 and the issue did not occur.

 

So....either there is some bizarre interaction between iCue and apps that report clock speed OR your program uses AVX instructions for some reason I am unaware of as a consumer. But atm....my clear choice is to unfortunately stop using iCue...which connects to about $500 worth of your products atm.

 

This does not happen with other applications similar to yours that I have from Steelseries, Gigabyte, Razer, etc.

 

Hopefully this can be addressed.

Link to comment
Share on other sites

I just set an AVX offset to test this (I normally have it at 0), and for me it always uses the offset in Windows, no matter whether iCue or it's service is running or not (Windows 10 1809). I'm running beta BIOS F8G on my Z390 Aorus Master.

 

Take it for what it's worth, on some other forums I've read that this is a problem with Gigabyte boards right now when AVX offset is set and not limited to iCue as it apparently happens after some sort of Windows Update.

 

I guess I'm lucky that I can run with AVX offset at 0 just fine on my Core i9 9900K with HT enabled (be it with the CPU clocked at 5Ghz/1.26V, 5.1GHz/1.320V or 5.2GHz/1.380V on all cores, even with AVX enabled in Prime95 Small FTTs with AVX for 24 hours - although at 5.2GHz/1.380V it gets a bit too toasty for my taste as the Core temperatures reach the upper 90s). I always get the full clocks on all cores with that, even with iCue running.

Edited by Glzmo
Link to comment
Share on other sites

Same issue. It seems to be isolated to the Aorus Master. This is lame. At least now I know what program is causing the problem. Come on Corsair. You can do better than this.

 

If it's limited to the Aorus Master, how, exactly, can you say it's the software? I mean ... if it was iCUE, wouldn't this hold across all motherboards? :confused:

Link to comment
Share on other sites

it isnt icue imo (for once), id venture a guess that 'turbo boost' is your mobo's factory-safe OC? you might have a power issue. Make sure the cpu has two 4pin power supplies if yours has two slots (my z390 does). I have a 9700k and diff. mobo which makes me think its either a software issue that your mobo company needs to patch (they might have not programmed a i9 9900k lol, it happens).

 

good luck tho

Link to comment
Share on other sites

Its not Aorus Master isolated...i have Asus motherboard and have the same problem...and troubleshoot is simple ... when i have icue enable i cant pass 4.7 ghz on turbo on any core....when i exit ICUE all its fine ...5.0 on 2 cores 4.8 on others 2 ......but i have corsair keyboard ,mouse ,cooler , mousepad , headset stand and ram...so i need it ... if you need any additional info im open for tests and etc...

As you see up in the post there is other guys complain also with asus formula XI..

I monitored the clock speed with 3 different programs ... and all gave same results..

Edited by LordSabathan
Link to comment
Share on other sites

Its not Aorus Master isolated...i have Asus motherboard and have the same problem...and troubleshoot is simple ... when i have icue enable i cant pass 4.7 ghz on turbo on any core....when i exit ICUE all its fine ...5.0 on 2 cores 4.8 on others 2 ......but i have corsair keyboard ,mouse ,cooler , mousepad , headset stand and ram...so i need it ... if you need any additional info im open for tests and etc...

As you see up in the post there is other guys complain also with asus formula XI..

I monitored the clock speed with 3 different programs ... and all gave same results..

 

I got the same problem. So deffo not isolated to Aorus

Link to comment
Share on other sites

Everyone knows how turbo boost works, right? If you set it as 50,48,47,47,47... You can only have the 50 multiplier active when only one core is doing something. 48 when two cores are loaded. 47 with three or more. iCUE does not tell your CPU or the OS how to manage its thread allocation. It's a multi-monitoring program. Your CPU thinks it is better to use multiple cores to do this. If you want your CPU to run the 50 multiplier on the desktop, then you need to set a higher core count to that multiplier. Having tried to play this multi-staged multiplier game before, my suggestion is you don't. It never works at the higher multiplier when you need it and a huge number of common programs will prevent you from actually using the higher frequency. If you want a useful 5.0 GHz clock speed, you need to set the BIOS for it.
Link to comment
Share on other sites

Everyone knows how turbo boost works, right? If you set it as 50,48,47,47,47... You can only have the 50 multiplier active when only one core is doing something. 48 when two cores are loaded. 47 with three or more. iCUE does not tell your CPU or the OS how to manage its thread allocation. It's a multi-monitoring program. Your CPU thinks it is better to use multiple cores to do this. If you want your CPU to run the 50 multiplier on the desktop, then you need to set a higher core count to that multiplier. Having tried to play this multi-staged multiplier game before, my suggestion is you don't. It never works at the higher multiplier when you need it and a huge number of common programs will prevent you from actually using the higher frequency. If you want a useful 5.0 GHz clock speed, you need to set the BIOS for it.

No need to explain me dude, i know very well .

That i need explanation is ... why when i exit ICUE everything work perfect... clock speed become 5ghz and turbo works flawless,and i have like 10 more programs on taskbar and i disable them for test and none of them except ICUE affect my clock speed.Obvious there is a problem , and its not in us..

Link to comment
Share on other sites

Good, then you understand your system is not able to achieve your single core turbo boost speed. If you would like to see what happen when your turbo boost is actually disabled, go into your bios and do it. If you don’t like the way Intel has advertised their clock speeds, ask them about it. During the conversation, ask them if desktop level programs have the ability to give your cpu behavior commands. The logic in this thread is flailing. If the program can’t control the cpu, then it cannot be responsible for its behavior. The cpu controls its own behavior and decides how to allocate threads and loads. Yes, it stops when you exit iCUE because you removed the load. So you would like Corsair to re-write the program so it does nothing? No monitoring, no controls, no programming. Maybe a little box with time and temperature? Don’t compare a multi-faceted monitoring program to your web browser. As everyone in this thread is on a 9900K across multiple motherboards, that should tell you the way in which Intel has chosen to balance the load across the 8 cores is at the heart of the issue. Go into your bios and set your CPU multiplier properly if you want it to run at 4.8 to 5.0.
Link to comment
Share on other sites

Good, then you understand your system is not able to achieve your single core turbo boost speed. If you would like to see what happen when your turbo boost is actually disabled, go into your bios and do it. If you don’t like the way Intel has advertised their clock speeds, ask them about it. During the conversation, ask them if desktop level programs have the ability to give your cpu behavior commands. The logic in this thread is flailing. If the program can’t control the cpu, then it cannot be responsible for its behavior. The cpu controls its own behavior and decides how to allocate threads and loads. Yes, it stops when you exit iCUE because you removed the load. So you would like Corsair to re-write the program so it does nothing? No monitoring, no controls, no programming. Maybe a little box with time and temperature? Don’t compare a multi-faceted monitoring program to your web browser. As everyone in this thread is on a 9900K across multiple motherboards, that should tell you the way in which Intel has chosen to balance the load across the 8 cores is at the heart of the issue. Go into your bios and set your CPU multiplier properly if you want it to run at 4.8 to 5.0.

Dude please ,you obviously ignore the problem here... so you intel need to remove turbo boost and we all need to manually OC the processors ( if we have free time ,because not of all have hours of oc and stabillity tests ) ,to dont have problem, when i have 10+ more programs and none of them affect my clock speed ... and for what Load you talk when i exit ICUE? this program doesnt load my processor more than 1%....im telling you if i unistall ICUE and everything is fine with the clock speeds ... why you cry about intel here,what they have to do with the ICUE... and maybe someone from the developer team can answer here ( or you are one of them) ?

Link to comment
Share on other sites

I am not really suggesting you disable your turbo boost. You would be most disappointed with the resulting clock speed (hello 3.6 GHz). It is relevant to this discussion because Intel does not promise you a 5.0 GHz clock speed on the 9900K. They promise a single core turbo speed of up to 5.0 under certain conditions. The primary condition is none of your other 7 cores are doing anything. Unfortunately, this condition almost never occurs.

 

The counterbalance to this is the motherboard manufacturers have for several years now used BIOS level tweaks to force all cores up to the turbo boost maximum. This goes by various names. Asus calls it "Multi-Core Enhancement" (MCE). This by default forces all cores to run at the maximum 4/6/8 core clock speed. It's been around long enough people have forgotten what happens when you don't use it. You get one core at the peak speed. That's it.

 

You guys keep clinging to this notion that quitting iCUE somehow paints it as the culprit. This is not the problem, but a consequence. You don't get 5.0 GHz playing games, running professional apps, encoding video, or likely even playing music from iTunes while browsing the web. Your CPU is allocating more than the number of cores allowed for the 50 multiplier to be in effect. iCUE does not tell the CPU I want to use 4 cores, please. The CPU assigns the tasks presented as it sees fit in accordance with its programming - not the app. What this demonstrates is the 9900K prefers to spread the iCUE load over more than 3 cores. That's it.

 

If you don't like the way Intel markets their CPUs or designs their behaviors, that is a conversation for them, however I don't think that will take you up onit. However, rather than continue to let this bother you -- fix it. If you want your CPU to run at 5.0 for all tasks, you need to set the multiplier to 50 for all cores and with an appropriate Vcore to match. Unfortunately, this per core overclocking is pretty much dead in the water. I tried quite a bit with my Hasewell-E CPUs and it was all for naught. Same problems you guys see here. The CPU was never at its peak clock, only the lowest. That was several CPU generations ago. I don't think things have gotten better and if anything even more effort has been placed into dividing load up and continuously shifting it between multiple cores. Multi-core overclocking is of very limited value. At this point if you set a 50/48/47/47/47/47/47/47 multiplier sequence, you are effectively running 4.7 GHz. It will only run the 5.0 for the occasional folder opening. Most people want more and you can have it, but you have to set it.

Link to comment
Share on other sites

I am not really suggesting you disable your turbo boost. You would be most disappointed with the resulting clock speed (hello 3.6 GHz). It is relevant to this discussion because Intel does not promise you a 5.0 GHz clock speed on the 9900K. They promise a single core turbo speed of up to 5.0 under certain conditions. The primary condition is none of your other 7 cores are doing anything. Unfortunately, this condition almost never occurs.

 

The counterbalance to this is the motherboard manufacturers have for several years now used BIOS level tweaks to force all cores up to the turbo boost maximum. This goes by various names. Asus calls it "Multi-Core Enhancement" (MCE). This by default forces all cores to run at the maximum 4/6/8 core clock speed. It's been around long enough people have forgotten what happens when you don't use it. You get one core at the peak speed. That's it.

 

You guys keep clinging to this notion that quitting iCUE somehow paints it as the culprit. This is not the problem, but a consequence. You don't get 5.0 GHz playing games, running professional apps, encoding video, or likely even playing music from iTunes while browsing the web. Your CPU is allocating more than the number of cores allowed for the 50 multiplier to be in effect. iCUE does not tell the CPU I want to use 4 cores, please. The CPU assigns the tasks presented as it sees fit in accordance with its programming - not the app. What this demonstrates is the 9900K prefers to spread the iCUE load over more than 3 cores. That's it.

 

If you don't like the way Intel markets their CPUs or designs their behaviors, that is a conversation for them, however I don't think that will take you up onit. However, rather than continue to let this bother you -- fix it. If you want your CPU to run at 5.0 for all tasks, you need to set the multiplier to 50 for all cores and with an appropriate Vcore to match. Unfortunately, this per core overclocking is pretty much dead in the water. I tried quite a bit with my Hasewell-E CPUs and it was all for naught. Same problems you guys see here. The CPU was never at its peak clock, only the lowest. That was several CPU generations ago. I don't think things have gotten better and if anything even more effort has been placed into dividing load up and continuously shifting it between multiple cores. Multi-core overclocking is of very limited value. At this point if you set a 50/48/47/47/47/47/47/47 multiplier sequence, you are effectively running 4.7 GHz. It will only run the 5.0 for the occasional folder opening. Most people want more and you can have it, but you have to set it.

Im sorry but at the moment you just guessing what ICUE can do and what cannot....i can guess also. it doesnt tell you processor to do anything ... just limit it somehow ... thats why i post here ,because someone with more expertise can give us some help....ill keep repeat to you, i cant reach 5.0 with ICUE turned on even on 1 % cpu LOAD... when i start the windows and it boost to 5ghz , and when ICUE started as process and bring it back to 4.7 ghz.... i cant reach more than 4.7 ghz even with 1% or 99% load on CPU and this is only with ICUE turned on... so please no more theories ... lets someone from the developer team give us hes thoughts on that...

Link to comment
Share on other sites

CPUZ & Windows Task Manager & Hardware info all read this info.

 

I did more testing last night and was able to reproduce it over and over and over again under the following conditions.

 

1) AVX offset set to 1, 2, 3, 4, etc.

2) CPU Multi Locked @ 50. System been tested prime stable 6 hours at this frequency, custom watercooled.

3) All C States, Speedstep, Power saving, and any other such feature in bios and windows disabled.

 

I start iCue and open CPUZ & Windows Task Manager & Hardware info, individually and all together. The readings are consistently 100-150-200-300Mhz CPU clock fluctuation.

 

I exit out of everything open CPUZ & Windows Task Manager & Hardware info, individually and all together.....CPU clock steady at 5Ghz as it should be.

 

I made sure I had every other application closed that I possibly could.

 

I went back into bios and set AVX offset to 0 and the issue did not occur.

 

So....either there is some bizarre interaction between iCue and apps that report clock speed OR your program uses AVX instructions for some reason I am unaware of as a consumer. But atm....my clear choice is to unfortunately stop using iCue...which connects to about $500 worth of your products atm.

 

This does not happen with other applications similar to yours that I have from Steelseries, Gigabyte, Razer, etc.

 

Hopefully this can be addressed.

 

Not reading all that crap about turbo states. I've locked multi @ 50 (all of them) and disabled all speedstep and c states. Been doing this for many many many years.

 

Simply put if an AVX offset is used, iCUE somehow triggers the offset. No other program is doing this for me and I am able to reproduce it over and over again.

 

So, to the iCue devs, does iCue use AVX instructions? If not has anyone looked into our concerns with the info given? Do you need more information from me (us)?

 

Second edit: I am emailing Gigabyte about this interaction as well since posts on previous page have similar hardware with same issue. If it is a gigabyte issue I'll update my posts. Thanks!

Edited by Wired
Link to comment
Share on other sites

 Share

×
×
  • Create New...