Jump to content
Corsair Community

K70 RGB MK.2 Stops Working Until Replugged


Honorable
 Share

Recommended Posts

My K70 seems to randomly stop working from time to time. All input stops working, but the lights stay on. Unplugging and replugging always fixes it immediately.

 

I have had the keyboard for several weeks with no problems, but this just started happening a few days ago. The time it takes it for it to stop working again seems to vary greatly from a couple minutes to several hours.

 

I have tried multiple USB 3.0 ports on the front and back of my computer.

 

When the keyboard stops working I see a red triangle in iCUE and clicking on the image doesn't do anything. In Windows device manage I still see the HID keyboard device even after it has stopped working.

 

128430611_Stoppedresponding.thumb.jpg.c96c954e57dd83766ea596d108c33915.jpg

 

My iCUE version is 3.10.25 and my keyboard firmware is v. 3.12 which is the latest. I have tried force updating the firmware on the keyboard. I have also tried resetting the keyboard to factory settings by holding escape and plugging the keyboard in.

 

I have tried restarting the computer both with the keyboard unplugged and plugged in.

 

I'm about out of ideas. Should I RMA the keyboard? It seems so strange that unplugging and replugging it always fixes it immediately.

Link to comment
Share on other sites

I have been having this issue since I got mine in November. It is only now happening often enough to cause problems. In the last 3 hours or so it's been happening every 5 minutes, which makes playing games or getting work done nearly impossible.

 

No luck with soft resets or using different USB ports having any permanent effect.

 

Just opened a support ticket. I'll let you know what I hear.

Link to comment
Share on other sites

  • 2 weeks later...

I contacted support myself and they told me to disable USB selective suspend which resolved my issue.

 

Please go to CONTROL PANEL / HARDWARE AND SOUND / POWER OPTIONS and then click on CHANGE PLAN SETTINGS (for your current default power plan). After that click on CHANGE ADVANCED POWER SETTINGS.

 

When new window opens, scroll down the list a bit until you hit USB SETTINGS. Click little square with plus in it, and then click another little square with plus next to USB SELECTIVE SUSPEND SETTING. Check the state of it, and make sure it's set to DISABLED.

 

After searching this forum for that keyword I was able to find other people who resolved their issues by disabling it. From my reading USB selective suspend is part of the USB spec. http://sdphca.ucsd.edu/Lab_Equip_Manuals/usb_20.pdf

 

Section 7.1.7.6 about Suspending starts on page 154.

 

Is Corsair not following the spec? It is incredibly frustrating that I was not able to find any Corsair FAQ explaining this.

Link to comment
Share on other sites

 Share

×
×
  • Create New...