Jump to content
Corsair Community

ICUE Won't Install


Silver79
 Share

Recommended Posts

So I have been using my RGB Strafe, Glaive, Void pro, and M800 polaris for awhile but I could never get CUE to install correctly. I had to revert to a old CUE1 build. I just got myself a lighting node pro, 6 LL120 fans, and commander pro being a large fan of the performance of corsair products I feel it's a great addition to the system. So I downloaded corsair link and got that no problem HOWEVER I still need ICUE. it installs up to 58% and freezes and refuses to progress. I've tried hard resets, Clean drivers, Deleting completely and reinstalled and every time same outcome. I can customize my LL120 fans or anything at the moment as its saying my commander pro is being used by CUE despite me not being able to install CUE and use it. I was hoping if there was a fix for this because currently I can customize any of my corsair products.
Link to comment
Share on other sites

  • 2 weeks later...

Having similar issues with my system. Cant get iCUE installed at all because it freezes completely while installing the driver. Even CUE 2 crashes at the same point. It used to work fine on my previous system build.

 

I tried removing other lighting sync programs (eg. motherboard and GPU) but still the same result.

 

Do you know what Windows build you're using? Finding a common factor could help find whats wrong.

Link to comment
Share on other sites

  • 2 weeks later...

I've had the same problem, for me, disconnecting the sata optical drive helped. There must be something with your hardware, for me it was the dvd drive... seems odd, but it happens twice for me already at two different PCs.

 

//one question, does it freeze at the drivers installation point ?

Edited by RaccoonV2
Link to comment
Share on other sites

 Share

×
×
  • Create New...