Jump to content
Corsair Community

H150i Pro not showing up in iCUE


Recommended Posts

I have upgraded from H115i Pro to H15i Pro and currently the iCue software isn't detecting the new cooler, although Windows detects it as "H150i Platinum".


- LED is working.

- Fans are spinning.

- SATA is connected.

- USB is connected.

- Fans cables are connected.


I tried to change the USB to an external. I plugged my previous H115i USB and tried also with my phone USB cable and connected it to an external. All these ways didn't work.


Although even If i use the original cable / H115i Pro cable / cellphone cable, I get the cooler detected in Device Manager as "H15i Platinum".


When I open up iCUE (latest version), it doesn't show H150i PRO. It did work with my old H115i Pro and showed it correctly. But this new cooler, it didn't work with it.


I have tried to restart, plug the pump in AIO instead of CPU_FAN, with/without the USB to see if something goes wrong, different USB header, all has the same result. It's not showing up in the software.


Furthermore, I'm getting this error in iCUE "ICUE macro execution is not working properly". I have tried to repair the installation, the message kept popping.


When I install both iCUE & Link, Link states that "H15i Pro" is being controlled by iCUE. When I open iCUE to check, I can't see the cooler! It's really irritating.


I'm completely frustrated. I have been connecting my 3-pack ML fans and new cooler and I'm only experiencing this issue from software side.


I have the latest Windows 10 and iCUE installed.





After uninstalling and installing again (latest version from Corsair.com downloads, the driver "H150i Platinum" has a yellow triangle. After trying to update/install the drivers, I'm getting the following error:


"Windows found drivers for your device but encountered an error while attempting to install them"



I did try reinstall Windows 10 Pro 64x. I'm still experiencing the same issue. Currently, the drivers cannot be updated and cannot be seen in Corsair Link.


I have uninstalled everything and reinstalled the latest version of Corsair iCUE. The driver is "Unknown device" and marked as "H150i Platinum".


Using USBDeview, the H150i Platinum has "1b1c" as VendorID and "0c12" as ProductID. It also shows that the type is "Unknown".


I'm not seeing "Corsair USBdriver" too (or anything related to Corsair in the Device Manager).


ML120 & RAM are still working fine and can be controlled via iCUE.

Link to comment
Share on other sites

  • 2 months later...
  • 1 month later...

I ran into this issue with the H150i AIO and an ASUS Crosshair VII motherboard during a new build last night. After reading several other threads, I noticed others are/were having the same issue. Decided to commend on this post as it's the most recent on my findings.


Credit to DevBiker, he's done a great job making recommendations on this topic (and many others). To summarize his recommendations, make sure you're using the latest version of iCue software, bios is up-to-date, firmware updated, etc. He also suggested to test with another USB cable, plugging the micro USB into the pump head and the other into a standard USB port (on the front display or back - doesn't matter).


After making sure the bios and all firmware was updated, I grabbed a micro USB and plugged directly into the pump head and then an available port on the back. Sure enough, iCue recognized the H150i pump and I could manage along with the Commander Pro. Device Manager also listed "Corsair USBXp Driver" now. Previously it wasn't displayed.


I speculated bad cable, bad header on mobo, pump connection, etc. After ruling out the pump, I wanted to rule out the USB cable that came with the H150i. After unplugging the Commander Pro from the USB 2.0 header on the mobo, I connected the H150's USB to the same header. iCue recognize the pump, Corsair USBXp Driver listed in Device Manger and I was able to control/make changes. This ruled out the USB cable.


I left the pumo's USB connected to the USB header on the mobo and connected the Commander Pro's USB into the other USB header (previously connected with H150i). Basically reversed what USB 2.0 header I was using (which initially corresponded to the manual). Now both the Commander Pro AND H150i are showing in iCue, I can manage both, and Corsair USBXp Driver is still listed in Device Manager.


Not sure if this will help others. I love troubleshooting, stepping through physical and configurations until resolved. What I've learned, make one change at a time and test. If the issue continues, make another change, test. Rinse and repeat until physical connections and configurations are ruled out. Along the way hopefully the issue is resolved. Making too many changes at once will only cause confusion (and possibly not understanding what actually corrected the issue). OK, soapbox over.


Thanks again to DevBiker and other contributors for their knowledge, experience, recommendations, etc.

Link to comment
Share on other sites

  • 7 months later...
Hello there , I recently got two Corsair ML120 Pro No LED case fans , I installed them but I am not sure if I done it properly , I connected them to the motherboard CH Fan 1 and CH Fan 2 , they are working and I also optimized them in bios with the fan control to PWM am I done it right or wrong ? Or is it anything else to do ? Please help ! Thanks !
Link to comment
Share on other sites


  • Create New...