Jump to content
Corsair Community

Vengeance Pro Firmware Update


Oxofrmbl
 Share

Recommended Posts

Hello,

 

I noticed that my RAM LEDs are not controlable in the ICue Software.

So i tried fixing it by myself, but restart und even a new ICue installation didn´t helped.

 

In the ICue Software i was able to use them as always and i could see every DIMM. It just did not change the Color.

 

I am using Icue 3.10.125 and my RAM Firmware 0.95.51(wich is interresting, cause the RAM says it wants to update to 0.96.57 but it immediatly says update to 0.95.51 after i confirm the update)

 

Anyways i hope you Guys can help me out. Maybe i just need a Firmware Image?

Link to comment
Share on other sites

I had the same problem

 

I need help i'm using ASUS Crosshair VII and my 2 week old Vengeance RGB Pro is not detected in iCue

 

so far i tried below

 

1. Downgrade iCue 3.9x and it worked BUT i need to keep on restarting services fr it to work and move the dimms which is crazy

 

2. Disabled Aura

3. Disabled SDK

4. Firmware says its already updated

 

I dont know whats next, can't sleep because of this

Link to comment
Share on other sites

I fixed it by myself.

 

Im not happy to tell you this but the only thing that worked was a complete new Windows installation.

 

If you have another ssd or a Harddrive laying around i can recommend to install it for testing. Maybe it works, but this is literally the hardest fix.

 

I hope i could help you. :biggrin:

Link to comment
Share on other sites

 Share

×
×
  • Create New...