Jump to content
Corsair Community

Lighting Node Pro LED Strips not working! Checked everything several times!


Recommended Posts

Hi everyone,


i just ordered a Lighting Node Pro RGB set including the LNP and 4 LED strips to complete my RGB setup.


I already have 3 LL140 fans that just work fine. All of the fans are on LED channel 1 (Chan1 to FAN Hub ) and i added the 4 LED strips ( in a row ) to LED Channel 2 but they arent working. ( not even lighting in any color ). I activated RGB Lighting Strips (4pcs) in ICUE on Channel 2 and i also tried switching to channel 1


I double checked everything:


- LNP can control fans, Channel 1 & 2

- LNP set up to straight SATA Power supply ( no adapter or sth )

- SATA Power is on 4.9X Volts

- LNP Firmware is up to date 0.7.122

- ICUE Software is up to date 3.9.93

- Tried every strip on its own ( straight to the LNP, including ICUE setup to 1 strip )


i checked everything several times but it doesnt work. i thought the LNP isnt working correctly so i decided to install the 2nd LNP i got from the Lighting Strip Set that included another one.


The result was the same. The fans are working properly but the lighting strips dont.


After trying everything for several hours the lighting strips started to light red. I was able to control them (rainbow wave, changing direction of the wave, constant lighting) but it was only showing red lights.


I replugged everything and it was working with 1 strip for like 20 seconds! Then it stopped working again ( no light ) and i wasnt able to set it back up.


Thank you for reading. I hope someone can help or give any advice to solve the problem.


Dont know what to do. maybe sth is broken but im very confused because it worked for a few seconds and i had 2 LNP to try.




Link to comment
Share on other sites

That sounds like they aren't getting power. Have you rearranged the strips or connected them one at a time? Do you have a multimeter and, if so, can you check the voltage supplied by the Lighting Node Pro? (Pin 1 is +5V, Pin 3 is Ground ... so you should have +5V between 1 and 3. Pin 1 will be on the right as you face the NoPro with the connectors towards you.)
Link to comment
Share on other sites

Hi, thx for your help @DevBiker.


One LNP is broken, 0 Volts on both RGB channels while operating and activated.


the second LNP is putting out 4,7 Volts but it seems like all of the strips are broken too. They cant connect properly to the LNP. they are kind of loose. if i dangle them around they work for half a second and all rgb lights are on.


i ll send them back to my vendor but i was very confused about it.


common... like one LNP broken and the strips are broken too or cant connect to a working LNP? are you kidding me corsair?


sadly EVERY corsair product i purchased so far was broken or atleast not 100% working.


i hope ill get a working set of strips. i removed the complete CoolerMaster lighting system from my computer to set up the corsair RGB system and now its dark inside my case except the 3 RGB fans....

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...