Jump to content
Corsair Community

New machine, H100i not recognized in iCUE


Recommended Posts

Hello, Corsair!


As the title states, I recently rebuilt my machine; it's now running Windows 10 Pro.


On my old system, I was able to look in the Corsair LINK software and see the H100i as well as modify its LED light.


Now that I've got my system up and running, however, it doesn't show up. I've swapped the USB 2 header it's attached to, to no avail. I've tried reinstalling LINK alongside iCUE; likewise, nothing.


What other steps should I try to see if I can get this working?

Link to comment
Share on other sites

I have the same issue. New build with CORSAIR HYDRO Series H100i PRO and Crystal 460x RGB case and cant get iCUE to see any devices. I have LINK and iCUE installed and neither one see the corsair gear. Link sees the motherboard, CPU and GPU but that's it.


iCUE says no devices found. Tried uninstalling and reinstall and still no love.

Link to comment
Share on other sites

Well, here's some weirdness.


My H100i is addressable through LINK now.


And I have no idea why.


I updated iCUE from 3.9.x to 3.10.125, thinking it was versioning, but no dice.


After I reinstalled, I thought "What the hell" and reinstalled Corsair LINK alongside iCUE, version -- and now it works.


Maybe upgrading iCUE provided the hook that Corsair LINK needed? I dunno.


Hope that helps, Gamester.

Link to comment
Share on other sites

  • Create New...