Jump to content
Corsair Community

Can't see K95 G keys in icue key binding interface...


Recommended Posts

Hello friends,


I was able to see and bind any kind of macro to my K95 Platinum's G keys. I needed a new macro a couple days ago, but when I tried to bind it I cannot see the keyboard interface where you can assign the keybinds and lights in iCUE.


Please see the screenshot attached.


I have spent quite sometime on Google and forums but I could not find any answers. Help please!


Many thanks.


Link to comment
Share on other sites

I have accidentally resolved the issue a couple of minutes ago. I unplugged the keyboard to blow out the cat hair, cookie crumbs and god knows what stuck in between the keys. Later on when I plugged it in, iCUE asked me to update the firmware once again, after re-updating the firmware the interface was fixed. I guess unplugging and plugging solved the issue because I have tried firmware update a couple of times yesterday.


We can mark this as resolved, happy days! :)

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...