Jump to content
Corsair Community

Dark Core RGB SE not being seen by iCUE


Recommended Posts

Dark Core RGB SE not being seen by iCUE when wired USB.

Using the 2.4 wireless is seen with no issues, however i believe you can only save the hardware profiles via wired. I have tried to update the firmware but as iCUE does not see when its plugged in it just hangs on the instructions.


Only got it yesterday!!! :[pouts: :sigh!:


UPDATE: Ok managed to get it to work via usb by finding and deleting the drivers. Also updated to the 3.19 firmware with no issues.

But i still can not load profiles - i get this error every time , "Device is no longer detected or there was an issue with saving to the onboard storage. Please reconnect your device and try again."

Edited by bm150
Link to comment
Share on other sites

  • 1 month later...

I have the same issue with my Dark Core RGB mouse. I'm connected directly to my laptop and I'm trying this with the 3.10.125 version of the iCue SW on Win10 and 3.19 version of the firmware.


I've tried this both with and without the wireless dongle connected. Same results. It seems lot of others are also having the same issue but with different models. (http://forum.corsair.com/forums/showthread.php?t=176580, http://forum.corsair.com/v3/showthread.php?p=988195, http://forum.corsair.com/v3/showthread.php?t=167540)


Can you help?

Link to comment
Share on other sites

  • Create New...