Jump to content
Corsair Community

HS70 and ST100 Unique Issue


Recommended Posts

I've been reading through the forums and can't seem to find a solution to this problem.


Here goes:


I've got the HS70 Corsair wireless headset and recently picked up the ST100 corsair headset stand. My ultimate goal was to clean up my desktop and no longer lay my headset on my glass tower case.


So I connected the ST100 stand to my computer and set it up. I then took the HS70 dongle from the back of my computer and inserted it into the ST100 stand. When I do that I get this issue with my HS70.


I cannot speak over the mic and listen to the headphones at the same time. I basically have to choose if I want to speak to my teammates or listen to my teammates. I've tried every variation on how to setup the HS70 and ST100 to make them both work at the same time.


I do use discord and in the voice settings for Input device I have to choose either ST100 or HS70 to speak and then the sound will not work on the Output device, even if the output device is set to ST100 or HS70. It will not work. And then to hear I can ONLY choose the ST100 to hear anything but then I can't speak over the mic even if I choose ST100, HS70, or default device. Bottom line is when the dongle is connected to the ST100 I cannot speak and listen with the HS70 at the same time. When the dongle is connected to my PC directly I can use both the mic and the headphones on the head set with no issues. But that kind of defeats the purpose of having the ST100. I should be able to connect the dongle to the ST100 and still be able to use my HS70 with zero issues.


Does anyone have any sort of insight on how to correct this? I know I'm not technically challenged by any means. But I honestly don't know what I'm doing wrong here.

Link to comment
Share on other sites

  • Corsair Employees

The ST100 is recognized as a distinct audio device in Windows because of the 3.5mm jack on the unit. Might just need some changes to your Windows settings.


Go to Control Panel>Sound

Right Click the Void Headset in Playback Devices

Select “Set As Default Device”


If the option to set as Default Device is not available, then please contact us again for further troubleshooting.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...