Jump to content
Corsair Community

Windows boots to black screen


Recommended Posts

I have the following issue with my new Corsair K95 RGB Titanium, Cherry MX Speed, German layout, - 2 days old, Part Nr CH-9127014-DE


Windows boots up, BIOS Splash Screen appears, Windows Logo appears briefly - Lights on the keyboard are active, then the keyboard goes dark, the computer screen goes black and the system longer responds.


This happens when I do a "cold" boot on a system which has been down for several hours. After that it's only possible to reset the pc by forcing a shutdown (holding the power button).


On the second boot, after a forced shutdown, this no longer happens. It also works fine when rebooting from Windows or when turning off the pc, waiting a minute and then turning it on again. It only happens if the pc was not active for a longer time.


System is a new build and only 4-5 days old:


Intel i7-9700K

Asus Maximus Hero XI Z390

32 GB Corsair DDR3200

Nvidia 1080Ti

Be Quiet DArk Base 900 with a USB and Audio front panel

Seasonic Prime Platinum Ultra 1000W psu


The connector marked keyboard is plugged into a USB Port: USB 3.1 Gen. 2 Type A. The second connector is not plugged in -from what I read online the keyboard only needs 1 connector on USB 3.0 and later. The only other device plugged into is a Logitech G403 mouse.


I also tried my old Corsair Vengenance K90 on my new system, which works fine.


Things I tried:


Unplugged all devices once the screen goes black, no reaction.

Corsair Bios is 1.07.123 - supposedly the latest, according to iCUE.

Mainboard Bios and chipset drivers are up to date.

Install of Win10 Pro is only a few days old and fully updated.

Corsair Composite Virtual Input Device - shows up under devices.

Corsair Bus also shows up.

Tried various plugin methods. Both connectors in older USB 2.0. Both in 3.1 and a single in 3.1. - same error.

USB Legacy Support set to Enabled (still gotta test disabled and auto)

Trying to switch to BIOS mode once the screen is black - no response from the keyboard.


Things I have not tried yet:


Setting the keyboard to BIOS mode and trying to do a "cold" boot from there. Also BIOS mode disables the macro options and the

K95 no longer shows up in iCUE.


This is ...weird....it's a brand new pc, other keyboards work and I had zero issues with this machine so far until I plugged in the Corsair keyboard.

Link to comment
Share on other sites

I think I was able to fix it - but I still gotta keep an eye on it, since I did several steps at the same time:


Plugged both connectors into the USB 2.0 ports

Unplugged the Mouse

Enabled the Mainboard's CSM Mode (in the BIOS), Compatibility Support Mode - enable to fully support the non UEFI driver add-on devices, or the Windows UEFI mode.


Roughly 4 hours since the last shut-down of my pc and this time the keyboard did not lock up during the first boot.


Gotta test these steps individually to figure out what was causing it....gonna report back if I can reproduce it.

Link to comment
Share on other sites



Separately testing the steps, this time I left the mouse plugged in while booting. Legacy mode on auto, CSM Mode on, both connectors plugged into USB 2.0 ports.


Pc was down for 5+ hours.


Turned it on and it once again stopped responding when booting into Windows. Had to turn it off and reboot, then it worked.

Edited by Hammerstein2k20
Link to comment
Share on other sites

Thanks, but on (enabled) was the original setting on my mainboard and it also produced the error. Although I did not have CSM on in combination with Legacy set to on.


I still gotta try a cold boot with the new firmware we got today.


Unfortunately it always takes so long to test every new setting, since the pc has to be turned off for a longer time, for the error to occur. If I just turn it off an turn it on 5 minutes later, the error won't show up.


It only happens when it was turned off for hours or over night. Really strange.

Link to comment
Share on other sites

The mainboard is brandnew and just a little over a week old now. And as I already said: this does not happen when I plug in my old keyboard.


Also if the battery was failing the BIOS would lose the date/time on every reboot as well spitting out CMOS checksum errors.


Next steps will be to test the new Firmware, to boot again without a mouse and to set Legacy to off - that's gonna take 3 days to test, cause I need my pc during the day :(

Edited by Hammerstein2k20
Link to comment
Share on other sites

  • Create New...