Jump to content
Corsair Community

LL120 fans not working after bootup


Recommended Posts

Dear Corsair,


Recently I have bought a triple pack of LL120 fans and installed them correctly per manual.


The problem is that almost everytime that I do a new startup my fans don't work, most of the times 0 of the 3 fans are lighting up or only 1 led of all fans is working.


What I already tried:

- Checked all the cabling, is OK (I have an IT background aswell)

- Changed the fans slot to see if there is a faulty fan, same problem

- Restarted iCue service

- Updated Lightning node firmware

- Reinstalled lightning node firmware

- Deleted and reinstalled iCue software


The strange thing is, that after a bootup and when I pull out the LL120 fans out of the lightning node pro and back in, they work perfectly again the rest of the day. And the second strange part is, last sunday I booted up my system and saw the fans were not working, tried every software related troubleshooting as stated above, didn't work but had to go to work. After around 5 hours I came back and found my fans working again?


So i'm not sure if it's a software related issue or a hardware related issue because if I pull out the fans out of the lightning node and back in they work correctly again.


System is a new built system with a fresh legal installation of Windows 10 Pro 64bit, so there can't really be the issue there either.

Link to comment
Share on other sites

So I waited a couple days ago.


It went good for 2 days and now I booted up my system again and only half of the leds glow up at all 3 fans, 2 fans are giving static light and the first one does give the standard rainbow theme but only on half of the leds.


If I now plug out the fans and back in again in the same slot they work perfectly again. I also tried to re-align them aswell but that doesn't work either?


Btw, the iCue software always sees the Lightning node and the fans, even if the fans leds are frozen at the same color after a bootup.

Link to comment
Share on other sites

Maybe try a "fresh" LNP installation, delete everything driver related (device manager) and connect the LNP to another internal USB-Header on your MB.


OK did this now, also enabled XHCI and disabled fast boot to see if it will work correctly now.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...