Jump to content
Corsair Community

Problem with Flash Voyager 1GB


Recommended Posts

Hi Ram Guy,


Do not know why my computer did not recognise the drive but my colleagues' can. I've tested it in 2 diff operating sys W2k & XP pro no problem & mine is W2k.

The driver is not loading at all. Below is a complicated situation:


1. Initially, I plugged it into a card reader's usb, it didn't seems to register. Unplugged & put it in a USB Hub port.


2. It registered & I saved some files into it without any prob but I try my luck again with the card reader & it fails again.


3. Installed the uitility that comes will it but once I activate it, comp crashes.


4. After rebooting, tried again in the card reader usb port but no luck again. Tot data was corrupted so I use W2k to format but it gave an error that the drive was unable to be formatted.


5. Brought to Office & use it in the comp, the drive can be seem but a default drive name. Data was corrupted so I re format with the office comp using W2k again.


6. That's it, drive couldnt be recognised any more. Went into this forum, realised that ppl use the ultility to format the drive. Then i suspect that i made a mistake using w2k to format it.Using my Colleague's comp (WXP pro) to install the ultility & reformat the drive. It WORKS! drive is back into action but still drive's name is removeable drive. To confirm, I went to another comp (W2k) no prob but back to my comp, no way.


7. Since than, I've done a Windows update on my W2k Service pack 4 but still no luck.


I'm sure this is not a defective stick, should blame it on my ignorant in handling devices.


Well, really hope that you can give me sound advice the what steps I should proceed with.


Thanks in advance,


Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...