Jump to content
Corsair Community

Unable to control Vengeance RGB through iCUE


Recommended Posts

Hello, got issues using the iCUE software with my memory. Any changes I make have no effect on the memory.


As of a few hours ago, I had no RGB software installed at all. I have an Aorus B450 PRO motherboard which allows me to control the RGB through the BIOS and the memory defaulted to the rainbow effect which I liked. So I thought I would install iCUE to see what other options are available. Well, that was a mistake...


After my initial install, one stick just turned off completely and the other one was stuck on rainbow. No matter what colour setting I select, it was stuck. Updated the memory firmware but then the memory was stuck with one LED at the bottom and top of the memory stuck on red, again... could not change it.


So I uninstalled iCUE and installed Gigabyte RGB Fusion which seems to work a lot better than iCUE and actually let me change the colours but one stick will sometimes become unresponsive and just have 1 bit of red at the top and bottom of the stick as if it's encountered an error.


In summary, things I've tried:


Installed and uninstalled both software multiple times

Updated memory firmware

Swapped memory sticks in their slots, also tried the two other slots

Updated mobo BIOS

Looked for DRAM SDP in BIOS but don't have that option.


So at the moment iCUE is uninstalled as it is beyond useless and RGB Fusion installed, I set the RGB to off but one stick still looks like it has encountered some sort of issue. See pic linked.


What do? I wish I just left it as rainbow and didn't try and install iCUE.......




Edit: Did a full shutdown, one memory stick is still showing two red lights and cannot be changed. Shutdown again and changed slots, same issue. Bad stick?

Edited by Sandals
Link to comment
Share on other sites

So I took the CMOS battery out and unplugged the system and left it overnight. Plugged it back in and the RAM lit up (not actually turned on the system yet) and one stick is flickering randomly and the other stick stayed off for about 30 seconds then did the red light at the top and bottom.


Think I'll take this to Corsair support, clearly something wrong with the sticks.

Link to comment
Share on other sites

  • Create New...