Jump to content
Corsair Community

iCue constantly loses connection


Recommended Posts



Firstly, is there not a search function on this forum? I'm assuming im not the only one with this issue but I couldnt do a proper search, so not sure. I went through 10 pages of forum and nothing, so I'll ask.


It seems that iCue just constantly forgets or loses connection to the keyboard (K63 wireless). It's been like this ever since iCue came out, and I've updated every version and reinstalled the firmware too.


Like if I just want to check the battery level or something, I open iCue and it just isnt there. The keyboard itself always works, I've never had an issue with that, and I'm typing this now on it!


I've tried closing and rebooting the software, doesnt help. The fix is just to unplug the USB wireless dongle, and it connects immediately. It's like a daily thing. I understand the battery level is in my system tray, but I'd still like to know why I can't interface with it in the software without unplugging it first, every time...


I also have a set of Void Pro Wireless, I never have an issue with those, and whether they are powered on or not the device is always visible in iCue, just not the keyboard.


Basically just wondering if this is a common thing, or if I am a one-off with the issue. If so, then I'd try to RMA it. Especially since last week I heard a high pitch buzzing when I had the thing on charge. Freaked me out a bit, though this week it is not doing it for some reason.

Link to comment
Share on other sites

Not sure what could be causing this. I have a Dark Core SE and it's never lost connection.


This is going to sound stupid but have you tried updating the firmware on the mouse itself? even if it says it's using the current one, force the update anyways. If that doesn't work, re-install iCue.

Link to comment
Share on other sites

  • Create New...