Jump to content
Corsair Community

My HS70 doesn't work after updating 0.64


Recommended Posts

I just bought HS70 today about 12.00pm from Thai shop, and i connected it to mu pc that made me felt it has a quiet mic volume, so i tried to fix it out by updating firmware via iCUE to version 0.64(at first time i was failed to update and i tried to force updating it till it complete.


Now my HS70 doesn't work, it cannot be switched on. The light indicator also does't work or show up any light.


I tried to reset it on its dongle by pressing reset button 5 seconds and then connected my hs70 with usb cable and pressed it till i haven't seen light on my dongle stay solid and stop blinking.


Now i'm so sad, i don't know how to reaolve it. Please help me.

Thank you very much and pls forgive my broken english

Link to comment
Share on other sites

  • Corsair Employees

The headset might be in bootloader mode. Try performing the following and see if this brings the headset back:


1) Volume control in min position

2) Hold the mute button while plugging in USB cable with the headset off

3) Release mute button 3 seconds after the USB cable is plugged in

Link to comment
Share on other sites

  • Create New...