Jump to content
Corsair Community

Corsair HD Fun / LEDs dont work


Recommended Posts



I'd read almost all post on this forum but I cannot find a solution.


I bought 6 HD Fun RGB last week. Untill yesterday, all of them worked perfect.


Yesterday I bougth a Commander Pro and now the leds on these fun doesn't works (only one, the first of these funs coneected on hub)


I tried to return to original setup but now only works one of them (first one)


I deleted LINK and ICUE software, installed and reinstalled, but same result.


I m waiting news from Corsair support.


Someone can help me? I can post some pictures (SIV or USBDeview)



Link to comment
Share on other sites

In the iCUE/Link settings, make sure you have selected your "Fan type" as HD and the proper number of fans (6). The program literally counts LEDs to make the effects works, so the wrong fan type or improper number will chop off the illumination.


Unfortunately, these things also work in series so a bad fan or bad port in the RGB Lighting Hub will block the subsequent fans from lighting up. If the fans and number are set correctly, try swapping a different HD fan into Lighting Port #2. If it lights up, it suggests the former #2 is a bad fan (lighting wise). It is also possible the short is after fan 1, but before fan 2 on the circuit.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...