Jump to content
Corsair Community

[BUG] iCUE + Scimitar Pro


neoiork

Recommended Posts

  • Corsair Employees

Hi, sorry to hear that. Never seen this before, and I couldn't come up with a reason why would a DPI function cause iCUE to crash. Have you tried the mouse on a different system and see if you get the same behavior?

 

And when it crashes, what kind of error message do you get?

Link to comment
Share on other sites

Hi all,

 

I've just bought this mouse an hour ago and I have the same error.

 

I didn't get any message, the application just hangs for a little until windows shows the typical message to force it to close.

 

I spent a lot of money on this mouse... please solve it asap...

 

Thanks

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 years later...

Hi !

 

I see that post is a few years old.

I don't know if the issue happens on very few people but I have the very same issue today with my newly acquired Scimitar Pro.

 

unknown.png

 

Here's a picture of what happens when I click on DPI.

No error messages unfortunately.

 

I forced latest update and didn't change that fact.

Link to comment
Share on other sites

×
×
  • Create New...