Jump to content
Corsair Community



Recommended Posts

This software needs to be worked on. It was working fine until the most recent update and it literally makes it so that I cannot click on anything and have to restart my computer to fix this. I've uninstalled, reinstalled, and it still does not work. Right when I hear the 'MIC ON' I'm no longer able to click on anything on my display unless I want to navigate my computer via keyboard...


When will this be fixed? I use iCUE mostly for my custom bindings and DPI, and it's really annoying that this manages to glitch my display.


I'm running a NVIDIA 1060 3gb so maybe it's an issue with the drivers? Still, this software should not have anything to do with my display in the first place...It's almost like a rootkit in disguise.


TBH I thought I had a virus, it acts like one.

Link to comment
Share on other sites

This doesn't sound like an iCUE problem but instead related to your hardware. We would need more information though for your system, OS, etc.


It worked fine until recently, and only happens when I run the iCUE application, how is this a problem with my hardware? My hardware is working perfectly fine. I hadn't changed any settings in the iCUE application and now it's just blah.



Time of this report: 9/19/2018, 22:43:47


Machine Id: {575D718C-B0CB-46E2-95F4-88E91A018494}

Operating System: Windows 10 Pro 64-bit (10.0, Build 17134) (17134.rs4_release.180410-1804)

Language: English (Regional Setting: English)

System Manufacturer: Gigabyte Technology Co., Ltd.

System Model: Z270P-D3

BIOS: BIOS Date: 11/08/17 12:23:02 Ver: 05.0000C (type: BIOS)

Processor: Intel® Core i7-7700 CPU @ 3.60GHz (8 CPUs), ~3.6GHz

Memory: 32768MB RAM

Available OS Memory: 32728MB RAM

Page File: 7415MB used, 30432MB available

Windows Dir: C:\WINDOWS

DirectX Version: DirectX 12

DX Setup Parameters: Not found

User DPI Setting: 96 DPI (100 percent)

System DPI Setting: 96 DPI (100 percent)

DWM DPI Scaling: Disabled

Miracast: Available, with HDCP

Microsoft Graphics Hybrid: Not Supported

DxDiag Version: 10.00.17134.0001 64bit Unicode



Display Devices


Card name: NVIDIA GeForce GTX 1060 3GB

Manufacturer: NVIDIA

Chip type: GeForce GTX 1060 3GB

DAC type: Integrated RAMDAC

Device Type: Full Device (POST)

Device Key: Enum\PCI\VEN_10DE&DEV_1C02&SUBSYS_373A1458&REV_A1


Device Problem Code: No Problem

Driver Problem Code: Unknown

Display Memory: 19351 MB

Dedicated Memory: 2988 MB

Shared Memory: 16363 MB

Current Mode: 1920 x 1080 (32 bit) (60Hz)

HDR Support: Not Supported

Display Topology: Extend

Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709

Color Primaries: Red(0.646008,0.329602), Green(0.310070,0.616711), Blue(0.151867,0.072766), White Point(0.313000,0.328625)

Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000

Monitor Name: Generic PnP Monitor

Monitor Model: GN246HL

Monitor Id: ACR02FA

Native Mode: 1920 x 1080(p) (60.000Hz)

Output Type: HDMI

Monitor Capabilities: HDR Not Supported


Advanced Color: Not Supported

Driver Name: C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_adc520364db29861\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_adc520364db29861\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_adc520364db29861\nvldumdx.dll,C:\WINDOWS\System32\DriverStore\FileRepository\nv_dispi.inf_amd64_adc520364db29861\nvldumdx.dll

Driver File Version: 24.21.0013.9924 (English)

Driver Version:

DDI Version: 12

Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1

Driver Model: WDDM 2.4

Graphics Preemption: Pixel

Compute Preemption: Dispatch

Miracast: Not Supported by Graphics driver

Hybrid Graphics GPU: Not Supported

Power P-states: Not Supported

Virtualization: Paravirtualization

Block List: No Blocks

Catalog Attributes: Universal:False Declarative:False

Driver Attributes: Final Retail

Driver Date/Size: 9/4/2018 8:00:00 PM, 952800 bytes

WHQL Logo'd: n/a

WHQL Date Stamp: n/a

Device Identifier: {D7B71E3E-5F42-11CF-2C51-37171BC2D535}

Vendor ID: 0x10DE

Device ID: 0x1C02

SubSys ID: 0x373A1458

Revision ID: 0x00A1

Driver Strong Name: oem47.inf:0f066de38c1dbfb9:Section102:\ven_10de&dev_1c02

Rank Of Driver: 00D12001

Link to comment
Share on other sites

you do not have dpi scaling enabled according to all that, perhaps try the very very newest nvidia driver? It was released this evening I think. Can't hurt! Others may have input. It happens when you first run the application on boot? Or only when you open it?
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...