Jump to content
Corsair Community

LL140 / Not detected in iCUE

Sacco Belmonte

Recommended Posts

The lighting node that comes with my LL140 kit is not showing up in iCUE or LINK


Anyone else?


I had tried one app installed at a time to avoid conflicts.


The LEDs work, the fans work.


The USBXp and the Lighting node PRO both show up in the system. Both appear to be working fine. (no warnings, all good)


BIOS's fast start is disabled.


I'm out of ideas.



Link to comment
Share on other sites

I'm using this hub. Didn't wanna mention it before so answers don't go directly to it as the culprit.




The hub works wonderfully and is SATA powered. There I have connected my LNP, my PCIe Firewire card communication port and my H500M controller. They're all recognized in windows and show up as fine in the devs manager.


They are all detected in windows, which makes me think the hub is doing its job just fine. I honestly have no reason to think is the culprit.


I would refrain from getting a NZXT hub. Is bulky and I would rather not mess with the RGB lights than having to try yet another thing.

Link to comment
Share on other sites

Here's the hub manual.


I already triple checked all connections are right. And as I said i can see all the devices in the PC, so no reason to think is faulty.


No firmware for that unit either, nor drivers needed as it seems to be hardware compliant.


I've highlighted the important bits according to the way the hub is installed.


The website states:


Because of current limiting features, the hub is not suitable for USB-powered hard drives, CD-ROM drives, mobile phones and similar devices.


From which I have none connected to it. This hub is being used exclusively for USB communication, not powering.


Link to comment
Share on other sites

Sooo ... I agree with you that the hub shouldn't be an issue. However, we should rule it out definitively. What happens if you plug the cable directly into the motherboard?


If that still doesn't work, what happens if you use a standard mini-USB cable and route it to a rear I/O USB port?


The NoPro does use some power from the USB hub - when I plug one in via an external cable, it'll pop up and can be configured even without having SATA power. That said, it's not a whole lot of current.

Link to comment
Share on other sites

I guess I can try. There's no real point other to see if it works as I don't wanna keep it like that and my board has two USB headers only and one is being used by the pump and only the pump for reliability.


Hmmm...I guess for science. :)


Yeah, let's just rule it out definitively. I'm using NZXT's hub as well as the hub in the Commander Pro, personally ... I don't think the one you have is available in the US. TBH, I like it a good deal more than the NZXT version.

Link to comment
Share on other sites

Ugh ... that totally sucks. I actually found that little puppy here in the US and was fixin' to get it.


I wonder though ... we've seen issues with AMD chipsets and internal hubs of any kind. I didn't look earlier to see if you had an AMD chipset and I should have. It has something to do with initialization and doesn't seem to effect all AMD boards. (Sorry that I can't be more specific than that ... basing it off of reports here on the forum, not personal experience.) Let us know if you experience the same with the NZXT hub - we have had reports of these kinds of issues with the NZXT hubs as well.

Link to comment
Share on other sites

Well. I'm gonna try that and report back. If it doesn't work then I'll return the new hubs.


Thanks a lot for your support regardless. :)


An interesting fact is that I also have my wireless PCIe card connected to the hub (uses USB for comm.) and it works just fine, Is affecting only the RGB controllers.

Link to comment
Share on other sites

I think I'm not even trying. There are multiple reports of fried USB controllers and external devices with the NZXT hub.


Jeez! ok....I'm staying away from any modification to my perfectly working fine PC.




EDIT: Seems like these reports are from the Gen1 version (no shroud). I've got the "ac-iusbh-m1" one.



I'm gonna plug them into the MOLEX from another PSU first before touching my MOBO, if they blow at least they can take the old PSU with them only.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...