Jump to content
Corsair Community

iCUE not proberly detecting rm650i or commander pro


Recommended Posts



Just got the rm650i and commander pro to control 6 LL120 fans.

At first it all worked fine. The PSU and commander pro was showing in iCUE and everything was fine. Not short after, the PSU stopped showing any data and after next reboot nothing is working. Neither the PSU or commander pro. Sometimes iCUE is detecting them (but not able to control them) and sometimes it wont. I checked with USBDeView that the commander pro is connected (it is).

Only way i can get it to work, is by reinstalling iCUE and everything will work fine until next reboot.

I've been reading a little on these forums and i had made sure XHCI handoff is enabled in BIOS. I tried using different USB headers on the motherboard. Updated the chipset drivers... I'm out of ideas.


Anyone got any ideas to a solution?

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...