Jump to content
Corsair Community

Another HS50 problem


Recommended Posts

Hello, I just bought the HS50 and like for so many others, the mic doesn't work.:[pouts:


I tried to just plug it with the Y-cable, it doesn't work.

I tried using my USB adapter, it doesn't work.

I tried plugging without Y-cable, it doesn't work.

I tried plugging the mic in the headset sloth and the headset in the mic sloth... lo en behold, the mic IS working but NOT the headphones. :eek:

I tried it without Y-cable in my Samsung phone and it was working.


I tried plugging another headset w/ mic in my computer to see if it was my computer not working properly, but this headset (with a Y-cable as well) is working properly.

If I plug that headset's mic cable with the headphones of my corsair, it works as well, so I really think it's a problem with the headphones' Y-cable.

By that I mean, the splitting doesn't seem to work properly.

OR, my settings, but I read at least 5 setting recs pages and they all say the same, and I tried it all...;):


I just want to know if there is something else I could try before I return it?


Thanks in advance for your help !

Link to comment
Share on other sites

  • 2 weeks later...


This topic is now archived and is closed to further replies.

  • Create New...