Jump to content
Corsair Community

H80i v2 "no devices detected" on iCUE

Recommended Posts



I'm trying to see my H80i v2 cooler in iCUE, but it's not showing. It was working once, and after that I just cannot seem to make it work again. I didn't do any change to the configurations. It just stopped working.


Things I already tried:


Uninstalling and Re-installing iCUE.

Removing Registry Keys

Disabling and Enabling device in Device Management


I can see the device in Corsair Link (, but it says "controlled by iCUE".


Thanks in advance!

Link to comment
Share on other sites

  • Corsair Employees
Have you tried restarting the iCue Service (there's a button under settings)?


If this doesn't work, attempt to run a repair on the installation as well. This can be accessed by running the installer again or going to "Apps & Features" in Windows 10.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...
Sorry to rehash this old thread, but I'm having the same issue and was wondering if the OP was able to fix the problem. Corsair Link is recognizing the H80i but it's not showing up in iCue. I'm also using the Commander Pro and have the USB cable that comes off the bottom of the pump connected to the USB port on the Commander Pro. Both fans are connected to each other with the provided cable and plugged into a single "CPU_FAN" header.
Link to comment
Share on other sites

  • 1 year later...
  • 4 months later...
  • 7 months later...

Yup... Done with Corsair. And I was considering your mouse over Logitech... wow

My corsair PSU failed last week. So glad I swapped for Seasonic now.
The last bit of Corsair in my rig is RAM and that will no longer be Corsair if I can help it.

You ended support for my i80H and so that is the end of my support to your company. We had lovely 8 years but now that my i80H fans are running on FULL SPEED and driving me crazy cos you took away fan control I promise you that I am going to deliberately chose any other brand than Corsair from now on.
I am just one man, but still... I always used to chose Corsair. Always! You betrayed me and so I hate you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...