Jump to content
Corsair Community

HARD RESET issues HOW many of you had similar experiences?


Recommended Posts

Hi, I've read in multiple times, people telling here that while trying to hard reset their keyboards, they bricked or almost happened. Well I have similar experience, is sthg there sthg that Corsair must adreess?


I have a K65 LUX RGB that started with some flickering issues, Corsair sent me a Firmware to download and the following instructions:




Thank you for bringing this up. (this is because the first time they've sent it they talked about a mouse and some other inaccuracy)

Here are the proper steps.

Many issues on our devices can be corrected by manually reinstalling the firmware.

Please follow the directions below:


1: Unplug your keyboard from the computer.

2: Locate the small pinhole underneath your keyboard. For some, this will be located near the polling rate switch by the cable. On others, it will be located underneath under the tilt legs

3: There will be a button in the pin hole that you will have to press with a paper clip or a pin

4: Plug your keyboard back into the computer, while holding down the pinhole button.

5: Once it is plugged back in, your computer should recognize a drive called CRP_Disabled. Please open this.

6: Download the firmware file from the ticket.

7: Delete the file FIRMWARE.BIN from the CRP_DISABLED drive, and then place the ISP file to the CRP_Disabled drive.

8: Once you have performed the steps above, please unplug your keyboard and then plug it back in. The device will then return to normal. Please test to see if the issue reappears. If it does, please inform us on the ticket for further troubleshooting.



Following the steps, point 5 and 7 NEVER happened and for a moment my keyboard didn't respond and I thought I've bricked it, Ive tried two times the steps above, and the keyboard didn't react and points 5 and 7 didn't happen at all.


I had to install iCUE, still not detected, I restarted my PC and there it was detected from iCUE, so I decided to update the firmware using iCUE, it worked and solve to an extension the flickering, it is better but not entirely, the issue persists in some keys.


The thing is: how many of you experienced similar situations?...Someone else had the problem of: recognize a drive called CRP_Disabled. Please open this


Is there sthg that Corsair must check? because the consequences here is probably bricking the keyboard


BTW while updating the Firmware throught iCUE, THERE YES for an instance appeared a sign telling me the whole "CRP_Disabled drive", but you can't do nothing when that happens, since it is during half the installation of the firmware.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...