Jump to content
Corsair Community

Install v3.6.109 update firmware, goodbye to the H150i Pro


Recommended Posts

I have been using iCUE 3.4.95 & everything was working well & my H150i Pro was showing up under the current devices, ** See H150i Pro Firmware version**



I then updated to iCUE 3.6.109 & got a prompt that there was a new firmware version for my H150i Pro



So I udated the H150i Pro firmware & then goodbye H150i Pro. It is no longer showing up.



I uninstalled iCUE, rebooted & reinstalled 3.6.109, still no H150i Pro showing. I uninstalled iCUE again, rebooted & tried version 3.4.95 again. Still no H150i showing.

I have even gone as far as installing version 3.1.133 & still no H150i Pro shows



What on earth is going on here? I have seen a couple of others mention that bits of hardware are missing once after installing 3.6.109. Surely there has to be some bad issue with this new version? To much of a coincidence


Any suggestions welcome



Link to comment
Share on other sites

I had the same problem when I upgraded to the 3.6.109 update. When I checked device manager the Corsair USBXp driver was not present at all. I had to uninstall 3.6.109 and reinstall 3.5.111 in order to get the driver to show in device manager again.
Link to comment
Share on other sites

Have you tried a cold boot?

Have you looked in Device Manager to see if the cooler shows but the driver is disabled?

Have you looked in USBDeView to see if the device appears there? (https://www.nirsoft.net/utils/usb_devices_view.html)


G'day Dev,

Yes mate, I had tried a couple of cold boots, even a threat with my work boots :laughing:


I had checked device manager & everything was fine there.


The rediculous thing is, now after starting my thread, I shut the system down. 12 hours later, I switched on & everything is back to normal.:question:


Has definately GMF.

But all is good now. Though there is definately something amiss with the latest update.

Link to comment
Share on other sites

There seems to be a number of issues with devices "dropping off" the radar after upgrading to the latest version of iCue. In many cases, it's just a matter of cold booting your PC for the MIA device to reappear. I for one had a problem with my Corsair memory disappearing from Dashboard which was fixed with a cold boot.
Link to comment
Share on other sites

  • 11 months later...

Hi can any one help me with this problem ?

H150i it was showing me new Firmware available when I was click to update It was showing me new available software so I update us well... after restart PC is flashing me my CPU fan not work. Then I open system and check ICUE app then I see my H150i is gone.

Link to comment
Share on other sites

  • Create New...