Jump to content
Corsair Community

Corsair VOID USB PRO 7.1 surround not working


Recommended Posts

I had this Corsair Void USB 7.1 for about 3 months, and surround worked fine. My sister played Minecraft yesterday, and she said she did nothing to the iCUE.


I came back today, turned on my PC and when i went on iCUE and tried to turn on surround (that i never turn off) and i see no diference at all, it sounds the same as Stereo. I tried changing USB ports, i already intalled yesterday iCue update today, and still not working, restarted and nothing...

Please help!

Link to comment
Share on other sites

  • 3 weeks later...

I have been in the same boat, i installed icue, and bamf, no more surround since.


Not sure why its doing this, but ehh, i won't be buying another corsair headset in the future.


spent at least 100 hours, trying to find a fix to this issue, when every other headset i have had didn't require any time investment at all...


Corsair, is bad, and their dev team, is bad.



Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...