Jump to content
Corsair Community

Issues With Commander Pro and H100i V2 - Fans Not Showing


Recommended Posts

I am currently using a Corsair H100i v2, four SP120 RGBs, two ML120 Pros and a Commander Pro. I only recently brought the Commander Pro, as I wanted more control over my case fans and extra RGB options for the SP120s. So I installed it, plugging in my four SP120s into the fan ports and plugging the SP120 RGB unit into the RGB port. However, when I booted up my system and loaded iCUE, the Commander Pro did not display any active fans, it only displayed 3 voltages and 4 temps (2 fans will occasionally appear and display random RPM numbers and then disappear). Furthermore, I have plugged in all 4 temperature nodes into the Commander Pro, but iCUE is showing all four temps as 0 degrees. I am able to change the RGB for all four SP120s, but I have no control over fan RPM what so ever.


Furthermore, I am having a similar problem with my H100i v2. I have my 2 ML120 Pros plugged directly into my H100i v2 and have its USB connector plugged into my motherboard. However, within iCUE the H100i v2 is only showing 1 fan and it is saying it is at 0 RPM, when I can clearly see both fans spinning in my case.


I have also noticed that the SP120s, plugged into the Commander Pro, and possibly also the ML120 Pros, plugged into the H100i v2, rapidly change their RPM every 10 to 20 seconds or so (I can hear them speeding up and slowing down). It seems like they are following some kind of pre-defined fan curve, but like I mentioned iCUE is not letting me control any of my fans, so I have no idea why they are doing this?


I have attached my view of iCUE


I hope someone can help,





Link to comment
Share on other sites

A few things...


1) You are missing the Performance Tab for the Commander Pro that allows you to change fan speeds. This was a common glitch on iCUE 3.4. Make sure you are on 3.5.111. If still the same issue, generally a restart of the program resolves the missing tab.


2) H100i v2 - Pump speed is way too low and fans show zero. Typically this means you have cut the voltage to the entire unit and it can't function within its normal parameters. Go into your BIOS and make sure the header powering the H100i v2 is set to "Full Speed" (EZ BIOS Q-fan) or Disabled (Adv. BIOS -> Monitoring -> Q-fan).


3) Generally when you see rubbish voltage readings or anything else that can't possibly be true, there is a software conflict with another program trying to access the same data. Are you running AI Suite, AIDA, HWInfo or any other monitoring apps? If so, close them completely, exit iCUE and kill the Corsair.Service (32 bit) in the Task Manager. Then restart iCUE normally. See if that returns normal values.

Link to comment
Share on other sites

Cheers for your quick response!!

I went through your suggestions and you have already helped me fix one problem so thank you!

  1. I am currently running iCUE version 3.5.111
  2. I have attached images of my current BIOS settings. [Adv. BOIS -> Monitoring -> Q-fan] shows the CPU fan control (I have my H100i v2 plugged into my CPU fan header) as disabled and in [Ez BIOS Qfan] I have the CPU Fan on PWM mode at "Full speed"
  3. I disabled HWinfo64 and the commander pro immediately started working THANK YOU!!





Link to comment
Share on other sites

1) OK, looks like it is back. Could have been interference from HWINFO. Either way, if this issue persists... report it. It was an annoying bug no one wants to see come back.


2) This part is concerning. BIOS appears to be set up correctly. The picture of the pump at 1100 rpm (should be 2900 at that setting) and 0 for the fans just screams not getting the right power. However, as they are spinning and not stop/starting, so I am hopeful this is still some kind reading glitch. Anything abnormal with your actual CPU temps? At 1100 pump speed I would expect the coolant to be warmer than normal and that passed onto the CPU. 28C is not overly warm and pretty normal for temperate zone summertime. (BTW, 1 speed sensor on the H100i v2, so 1 "fan dial" in software is normal for all programs)


3) You still can use HWINFO, but when you launch there should be a prompt to disable Corsair monitoring. Accept it. That will put red Xs on the C-Pro and cooler, which you can see in Link. You will also get a warning about the Asus embedded controller, but you can ignore that one if you like. Disabling it will prevent you from seeing accurate motherboard, VRM, PCH temps, etc. which is the whole reason to use HWINFO concurrently with iCUE, which does a poor job of reporting motherboard values.


*Actually, before you do this. Quit iCUE and launch HWINFO normally. What does it say for the H100i v2 pump and fans?

Link to comment
Share on other sites

Average idle temps for CPU package around 30-40 degrees atm, so nothing worrying there


I've attached images of the temps shown in HWinfo for the H100i v2, it doesn't seems to be changing from those values


Do you think changing the CPU FAN mode in the BIOS, from PWM to DC would help at all?


Thanks again for your help!



Link to comment
Share on other sites

In HWINFO, did you get a Pump and Fan 1 reading just below "H100i v2" Liquid Temp? They should be there. If not, that further underscores some kind of detection issue.


Toggling PWM/DC in Q-fan should make no difference at all. I believe on Z370 "disabled" is technically 100% DC, but it is 12v either way. The PC presumably boots without getting a "CPU Boot Error", so the BIOS must be getting some reading. When you are in the BIOS, what speed does it show for CPU fan? It should show 1/2 the actual pump speed, so typical BIOS values would be ~950 to 1000 for Quiet mode or ~1400-1500 for the high pump setting. If it shows 500 rpm, then I am worried iCUE is accurate.


The last thing to try is to move the H100i v2 connector to a different header. I think you have an "AIO" header on that board, but any CHA fan header set to 100% works as well. The trick is something does need to be on CPU fan to boot (or disable the error warning). However, for a test procedure, I might just stick some random fan on CPU fan to see if 1) it works on CPU fan; and 2) to see if H100i v2 does better on something else. It should make no difference, but... AIO should be preset to run at 100%.

Link to comment
Share on other sites

Unfortunately HWinfo is not displaying a "H100i v2" Liquid Temp, so something going wrong there then.


Yeah PC boots fine, no errors. Checked BIOS and it is reading the CPU Fan RPM at around 1450RPM


Ill have a go at switching fan headers see if that does anything!


Link to comment
Share on other sites

Well, that is probably good then. ~1450 is exactly what the BIOS should read when the pump is set to the high setting (Extreme in iCUE). So no hardware problem, no CPU fan header problem.


That brings us back around to why iCUE is misbehaving. My understanding is the HWINFO driver piggy backs off the Corsair.Service to get the pump info. Both are missing data. When you loaded HWINFO, did you use the "installer" version or the "portable" version? It is possible if you use the Installed version (will show up in program list in Windows) the HWINFO driver is staying active when you would rather it not. The portable version deploys and recalls its driver on launch and exit. This seems a bit dramatic, but I am running out strings to pull on. If you copy your HWINFO64 Configuration file and drop into the new portable file location, you won't have to do all your settings again.

Link to comment
Share on other sites

So I had a hunch that my mobo/Asus was monitoring fans speeds/temps even without me running AI suite, so I uninstalled all the Asus utilities I wasn't using, including AI suite. I then for good measure went into my BIOS and set all fan headers to 100% just in case.


One or both of these things fixed it and iCUE is now perfectly displaying the H100i temps and fan RPM.


Thank you c-attack for all your help, I'm sending you an internet high five!!

Link to comment
Share on other sites

You know, it's my fault for directly asking about AI Suite. It hadn't come up in the discussion and I wrote it off as not installed. That thing has deep tentacles and there is no "not running" other than you have wiped it with the Asus removal tool or some other professional software. On the bright side, there really isn't much reason to use it anymore. All of the "fan delays" and control options that used to be exclusive to it are in the BIOS (Adv) -> Monitoring -> Qfan section. That doesn't give you desktop control, but if you need that there may be better options. Anyway, glad this is sorted.
Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...