Jump to content
Corsair Community

K70 RGB LUX Issue - Not recognized by system


Recommended Posts

Ok, so everything was working fine 10 days ago. I go on vacation, come back and my keyboard is kaput.


First it would light up fine but it was like someone was holding the CTRL key down and no other keys would respond. So I rebooted (when in doubt, reboot).


Well, after that, NO lights turned on except for the 3 indicator lights next to the volume control. They all light up solid white (no flashing).


The keyboard is not recognized at all. So I tried the "soft reset" by holding down ESC and plugging the keyboard back in. Literally nothing happened. No matter how long I held down ESC, it didn't flash it didn't do anything.


So then I uninstalled CUE (I had the 2.whatever version) and installed iCue.


For a brief moment, everything worked after that. iCue saw the keyboard, the keys worked, yay!


Or so I thought...


I then unplugged the keyboard to plug it into a different port -- and it went back to the whole 3-indicator lights thing. So, I tried plugging it back into the other ports it was working on a few minutes earlier, no go.


I've since tried the soft-reset again (nothing happens). I've uninstalled and reinstalled iCue, no go. I've done the repair installation on iCue, no go.


I even tried replacing the firmware via hard reset, that also did nothing. (As per: http://forum.corsair.com/v3/showthread.php?t=179798)


So ... help?

Link to comment
Share on other sites

  • 2 weeks later...

Heya Meatnog,


I'm running into literally the exact same issue with my K70 RGB Lux. Got it last Christmas as a gift, and it was working fine until Sunday, August 19. I had gone away on vacation from August 8 - August 12, and used the keyboard on August 13-17, with a break from gaming on August 18 (Saturday). When I booted up on Sunday, August 19, I was met with a flashing keyboard, the 'Ctrl' always-on effect you mentioned, and mostly unresponsive keys. I was using iCue, so I closed it, and while the lights changed back to default, they persisted in their flashing.


I then did some internet research, which is what you did, finding the same forum link with the bin file from the iCue Product Manager, Corsair James. I used this fix, and it seemed to work for a good 20 minutes or so, and then the problem came back.


I opened a ticket yesterday evening, both with Tech support, as well as RMA. Haven't heard back, but it's only been 24 hours. I recommend going to support.corsair.com, and creating a ticket ASAP.


Good luck, and if you remember, please post here if / when you find a solution. Thanks!


*Quick edit: I typed this on my ancient Logitech G15 (purchased 2006), whose only problem is wonky backlights.

Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...