Jump to content
Corsair Community

Windows Installer Doesn't See NX500


Recommended Posts



I recently picked up an NX500 and hooked it up to my computer. From the start, my BIOS and my Windows disk wouldn't see it.


In Windows, from my existing install on another SSD I managed to provision the drive in NTFS is Disk Management. That made the drive show up while I'm booted into Windows.


After that it still wouldn't show up in BIOS or Windows Installer. I updated both the firmware of the NX500 and my BIOS. It still doesn't show up.


I'm having trouble googling any more solutions. Last thing I've tried is unplugging every drive except the NX500 but it still doesn't work.


EDIT: One proposed solution I found said to make a UEFI Windows thumb drive rather than my disk. This indeed makes the NX500 show up, lets me install Windows and delete it. But upon finishing and restarting, the installer just takes me back to that screen rather than continuing, taking out the thumbdrive I get the error "The current bios settings do not support the boot device"


Anyone have an idea what else to try?

Edited by Lanceo90
Link to comment
Share on other sites

  • 2 months later...


Older MB's don't support booting from uefi, so these ssd's don't even show up. I got it to work on my Asus P9X79 by modding the bios. Its obviously risky and not supported but worked for me. My NX500 now appears in the bios and I'm using it as a boot drive for windows 10. Anyone looking for a fix can follow this well written step by step guide..... if you're willing to take the risk!


Edited by macca1
Link to comment
Share on other sites

  • Create New...