Jump to content
Corsair Community

D key only goes red


chocobo
 Share

Recommended Posts

Hi there,

 

My D key only goes red. I first noticed the problem today after a few months of owning the keyboard.

 

I've tried to use it on another PC with iCUE installed, with no luck.

 

Set to a static white colour, it looks like this:

https://i.imgur.com/0PcnI7E.jpg

 

On my default profile with a static blue colour, the D key is not lit up at all, but goes red when the ripple effect starts.

 

Any advice would be much appreciated.

Link to comment
Share on other sites

  • Corsair Employees
Hi there,

 

My D key only goes red. I first noticed the problem today after a few months of owning the keyboard.

 

I've tried to use it on another PC with iCUE installed, with no luck.

 

Set to a static white colour, it looks like this:

https://i.imgur.com/0PcnI7E.jpg

 

On my default profile with a static blue colour, the D key is not lit up at all, but goes red when the ripple effect starts.

 

Any advice would be much appreciated.

 

Hey there, try reflash the firmware via our iCUE software first, but if that doesn’t solve your issue, please go to our support site and open an RMA ticket with us.

Link to comment
Share on other sites

Hey there, try reflash the firmware via our iCUE software first, but if that doesn’t solve your issue, please go to our support site and open an RMA ticket with us.

 

No luck with that unfortunately. I will have to log a RMA case. Thank you for the assistance.

Link to comment
Share on other sites

 Share

×
×
  • Create New...