Jump to content
Corsair Community

Hydro Series H150i PRO RGB 2 fans inside?


Ektelion
 Share

Recommended Posts

Come on guys really? I can't believe products on this level of cost have such unprofessional executions.

How could you possibly pack up something of this cost and forget including one of the 3 fans?

This is the second time I am experiencing problems with your products in the last 2 months, this is totally unacceptable.

What am I supposed to do now? Rma this thing and get it replaced in 1 month ? This is laughable.

I even wonder if the PSU I ordered from you is gonna work in the first place since its still wrapped up.

Very upset atm since I cant complete my build because of this

 

https://imgur.com/a/52rCcuq

Edited by Ektelion
Link to comment
Share on other sites

  • Corsair Employees
I do apologize for the troubles, this is certainly a first that I've seen especially with the Prr coolers themselves. I would suggest to get a ticket created with the support portal and the Technical Support team can further assist you.
Link to comment
Share on other sites

I do apologize for the troubles, this is certainly a first that I've seen especially with the Prr coolers themselves. I would suggest to get a ticket created with the support portal and the Technical Support team can further assist you.

 

It looks like i cannot submit a ticket, it says Error

Product Description is required

 

i called my reseller and they said the exact same thing, they agree to send me a fan from their side with their cost but we don't know which exactly fan is the radiator using since its confusing, do you have a link for which exact fan it is?

Link to comment
Share on other sites

I am not sure they independently sell the ML120 "Quiet" version that ships with the H150i. You may need to deal with Corsair directly for that or perhaps there is another acceptable solution.

 

Copy the part number off the box, then hit "check part number" to lock it into place. Presumably CW-9060031-WW but confirm from the box. Either copy and paste or direct typing is better than sifting through the scrolling list.

Link to comment
Share on other sites

I am not sure they independently sell the ML120 "Quiet" version that ships with the H150i. You may need to deal with Corsair directly for that or perhaps there is another acceptable solution.

 

Copy the part number off the box, then hit "check part number" to lock it into place. Presumably CW-9060031-WW but confirm from the box. Either copy and paste or direct typing is better than sifting through the scrolling list.

 

I have a ticket submitted with the Number #757837

 

If anybody in charge can see this please i want this resolved as fast as possible since its obvious that i cannot build my computer without the radiator. :sigh!: :feedback:

 

Edit*

 

If anybody has even the slight of assumptions that i made this up to get an extra fan let me tell you that the whole computer build cost me around 2500 euros total, it would be laughable for me to create a whole fuss about a 20~25 euros fan, simply the radiator came with 1 less fan in the box :/ that's all there is to it.

 

Here's a picture of my Rig, i am waiting for my Monitor to arrive Plus there was no room in the photo to show you the 570x crystal case aswell. https://imgur.com/a/OIeOXue

Edited by Ektelion
Edit for clarification + Photo of rig
Link to comment
Share on other sites

I don't think that anyone assumes that you'd make this up. Hopefully they'll get you sorted quickly.

You could run that radiator with only two fans, by the way ... it'd still work just not be as efficient. And probably a little bit louder.

Link to comment
Share on other sites

  • 3 weeks later...

Updating my status regarding this issue.

 

After contact through RMA with corsair they agreed to replace my unit entirely since they had no fan of the same type to send me, god only knows the cooler is gonna last the 5 year warranty.

 

The new one arrived 2 days ago.

 

Everything seemed fine until I started building my brand new Pc , here starts the funny part.

 

The included Node pro inside the crystal 570x case was half functioning, meaning that 2 of the 6 ports didnt work, I won't make a fuss about it since I had an extra node pro in the box of the 3ML rgb fan pack that I had ordered and I completed my pc with it after 15 days of delay because of the radiator.

 

I wont comment on the case not having the shroud cover of the PSU but it has holes to screw one up there. Wtf???

 

You definitely need to step up your quality guys, we're paying end game premium stuff to have issues like this?

Link to comment
Share on other sites

Can Confirm

 

bF1oj5Rl.jpg

 

Can confirm aswell on the second product though, because on the first one there was nothing there in the first place.

 

I had no clue at start it was supposed to be on the left side thus that's why i didn't take the picture of the whole package, the spot of the 3rd fan was filled with the plastic box of the Plating to mount on the Cpu

Link to comment
Share on other sites

 Share

×
×
  • Create New...