Jump to content
Corsair Community

HS70 Not Connecting


Slater0
 Share

Recommended Posts

There is very little information on the web for this new product. I just bought it and installed it. And then installed the iCUE software. It seems like it is working, there's hum, and there are noises when trying to connect? (wireless), and noises when you turn it on and off. iCUE says the device is "not connected". Windows shows it set up as the default, but when i run the troubleshooter it can't find a solution.

 

I unplugged it and installed another headset (corded) and it worked instantly. So I know its not so much windows.

 

So that leaves me with iCUE saying that its not connected. Now no where in my HS70 booklet or on the Corsair webpage does it tell me how to manually connect the wireless transmitter to the headset. Can anyone help?

 

Thanks

Link to comment
Share on other sites

So I saw this under the "Support" FAQs for the VOID PRO RGB Wireless headset

 

16.How do I pair my headset to the wireless adapter?

 

First you will need to use a paper clip to insert to the small hole under the white LED on the wireless adapter. Press and hold it for a few seconds and the white LED will begin rapidly flashing. Then on the headset press and hold the power button (while the headset is off) for 8 seconds, if done correctly the LEDs on InfoMic will begin flashing green and red. Once the headset is paired, InfoMic will indicate that it is paired by pulsing green and the adapter will no longer rapidly flash.

 

At first I didn't think my wireless adapter had a hole, but later I discovered it on the side of the adapter and not on the face with the light. Now my headphones work :laughing:

Link to comment
Share on other sites

  • Corsair Employees
Help me why is it my new hs70 no sound at all? i did connect it and iCue can detected it i can even see when i mute the mic from the headset but there is no sound at all?

 

Did change your default output device to the HS70 in your sound settings? Also, don't forget to adjust the volume on the headset earcup slider itself, it's separate from the Windows volume levels.

Link to comment
Share on other sites

Did change your default output device to the HS70 in your sound settings? Also, don't forget to adjust the volume on the headset earcup slider itself, it's separate from the Windows volume levels.

 

 

i already did that and everytime i connect the bluetooth device into pc it say's the device not installed properly but when i check the iCue i can see the headset icon over there i'm using windows 7 anyways pls help :(

Link to comment
Share on other sites

  • 1 year later...

Hi,

 

I m unable to set up my corsair HS 70

 

The device show error in the device manager with the following details:

1) "Window cannot verify the digital signature for the drivers required for the device. A recent hardware & software change might have been installed a file that is signed incorrectly or damaged, or that might be malicious software from an unknown source. (Code 52)

 

2) Driver version : 2.3.22.0

3) Driver date 2/13/2020

 

Kindly assist

Link to comment
Share on other sites

 Share

×
×
  • Create New...