Jump to content
Corsair Community

Change (all) Corsair Elite One usb ports to 2.0


vicour
 Share

Recommended Posts

Does anyone know how to change the Corsair Elite One usb ports to ALL be 2.0? All of my peripherals are acting very strangely, due to being usb 2.0 and not really compatible with usb 3.

 

Can the usb ports be changed in the bios to all function as usb 2.0 instead?

Link to comment
Share on other sites

Given that USB is backwards compatible I'm surprised to hear that. I have the same joystick, and I've never had any problems using it when it's been plugged into a USB 3 - or 3.1 port.

 

Are you plugging it directly into the One, or using a hub?

 

When was the last time you updated the drivers for it? (http://support.logitech.com/en_gb/product/x52-space-flight-simulator-controller)

Edited by MadHatch
Link to comment
Share on other sites

I have tried both usb 3 and usb 2 ports, plugged directly into the Corsair, or through a hub, loading the updated drivers you linked, or reverting back to windows drivers.

 

All produce the same result: input lag, every few seconds, the joystick and throttle lose input, freezing up, then input returns, a few seconds, then it freezes again a few seconds, etc, and repeats this forever.

 

I used the same stick previously (specifically, Saitek x52 NOT pro) on a windows 8 PC with no issue.

Edited by vicour
Link to comment
Share on other sites

  • 2 weeks later...

Update on this:

 

I have two systems currently, the corsair elite one and my older system, a win8 PC.

 

Both systems have both usb 3 and 2 ports. I tried to use the x52 on my old system, which used to work fine, and it exhibited the same behavior. (input lag freeze every few seconds) I tinkered a bit, uninstalling drivers and such, then plugged in the x52 to the Win8 machine's usb 3 port, windows installed some drivers, and it did the same input lag freeze. However, then I plugged it into a usb 2 port on th Win8 machine, and it worked smoothly!

 

I tried to replicate these same steps on the corair elite box, but I cannot replicate how it works on the Win8 machine. (input lag freeze no mater what I do) This clearly seems tied to usb 3 and 2 ports in some way.

 

Does anyone have any insight into this? Different drivers? Different usb port configs? I feel like I stumbled onto something, but can't narrow it down.

Link to comment
Share on other sites

 Share

×
×
  • Create New...