Jump to content
Corsair Community

Side buttons dont work (scimitar RGB)


fer_gonzalez
 Share

Recommended Posts

I just bought this Corsair Scimitar RGB mouse and the excitement quickly became disappointment. First thing I tried to do after installing the iCue was changing the mouse light effects, and noticed the side buttons light wasnt working no matter what effect I apply, all the lights but the side buttons always work but thats OK, who cares?

So I decided to set up the side buttons, looked up for many tutorials and got everything right... But it didn't work.

I assigned the F buttons for the G so G1=F1, G2=F2 and so on till G12=12

When I first opened the game (Tibia, yes people still play that lol) my character started spammimg F1 like as if I was holding the button (there is an option to keep it pressed but it is not marked, I've tried to mark and unmark it back again later).

It keeps the button pressed for about 4 seconds, then 4 seconds working properly and repeats the cycle.

 

PS. During the 4 seconds working "properly", only the G4 button works but not on the key it was designed to, it presses F1 ou F7, F5... everything but F4 as said it should

PS 2. When I press the G4 button, some blueish light goes on below the scroll, lightning the mouse and mouse pad, the the other 11 side buttons it does not happen.

PS 3. Its not only ingame, when I open a Google Chrome window, it keeps opening the Help tab (F1 is the shortcut to it), if I set G1 as Alt + Tab its 4 long seconds switching programs, if I set it as F5 it refreshes the tab like crazy.

PS 4. Sometimes when using the iCue, my headset gets disconnected and I need to unplug and plug it back on to work properly.

PS 5. I already contacted tech support via chat and phone yesterday, so I've tried to update the software to its latest version, tried to look for other versions on the support forum, opened a ticket and got a link to a version from tech support that was supposed to work - didnt either. So as told by them, I tried a hard reset as last resource and failed again. Between diferent versions of the software, I always uninstalled the whole program and ran the Ccleaner to make sure it was gone, like instructed by the phone

 

Is it an Issue with the mouse piece itself? Is it something related to Windows 10? Is it the iCue? (I've been reading lots of bad comments about the software)

 

Sorry for my bad english but I tried

Edited by fer_gonzalez
Link to comment
Share on other sites

 Share

×
×
  • Create New...