Jump to content
Corsair Community

Wont type, Static Red/White light


AlphaDog56
 Share

Recommended Posts

I was in a game of CS, then my power cut off. I restarted it obviously and for about 1 hour the keyboard was perfectly fine. Then it froze and shut off completely. I rebooted my pc multiple times, changed the notch on the back multiple times, and even soft reset it. When I soft reset it the first time, my RGB lighting went back to my setting, and the keyboard works for roughly 5 minutes. Then the lighting froze, and the entire keyboard went black. I soft reset it again, worked for roughly 5 minutes again, then did the same thing. Now it won't type at all, and now I have a constant Red lighting, with white lights on the A, W, S, D, and arrows keys. I tried changing USB ports, and even computers. When I plug it up now, I get USB device not recognized. Then when I got to devices, it gives me an Unknown USB Device( Device Descriptor Request Failed). Note: I bought this brand New from eBay, still in the box wrapping ECT. But I don't think Corsair will replace this item since it was from eBay. So that's why I haven't made a ticket. Can somebody please help, I've only had this product for like 3 weeks. Also, ICUE doesn't show the keyboard connected obviously, but in the device manager, It shows HID Keyboard. Edited by AlphaDog56
Added last sentence
Link to comment
Share on other sites

 Share

×
×
  • Create New...