Jump to content
Corsair Community

iCue not working


pjmavcom
 Share

Recommended Posts

Just got a K95 Platinum keyboard. Looks great, works and all. iCUE does not work. Or CUE for that matter. Downloaded and installed both, iCUE 3.4.95 and CUE 2.24.50. Neither load. I get nothing on screen. When I hover over the taskbar tab, nothing shows up, just an empty window. Id like to blame this on Windows new involuntary update pushed out a few days ago (maybe longer, I just got it) because now my usb 3 monitor doesnt work anymore.

Ive tried deleting/ renaming the Corsair folder in appdata, uninstalling, reinstalling, iCUE and CUE both. Still not able to get it running.

Closest I got was running in compatibility mode for Windows 8, run as admin, and I got a title bar to pop up. No close buttons or anything, but thats still it.

Help would be appreciated, as the rainbows floating behind my keys can get a bit annoying. Thanks!

Edited by pjmavcom
Link to comment
Share on other sites

Thanks for the reply. I just updated, uninstalled and reinstalled all the drivers that came with this computer. BIOS, chipset, video, all that. No luck.

I installed a virtual machine with a clean, unupdated Windows 10 on it. Managed to get the software to work on it, so I can get rid of the rotating rainbow now. But now I see what this can do, I want it to work now. Im missing out!

Link to comment
Share on other sites

It sounds like you may have an issue with OpenGL. iCue using OpenGL to do the graphics and screen display.

Couple of things ... make sure that your video drivers are up to date.

Check your BIOS and make sure that the Primary Graphics Adapter is set to the discrete GPU. Not sure if this is feasible on a laptop as they tend to have limited BIOS settings.

Check your video drivers and make sure that they are up to date.

 

Also, can you export your log files? There may be something in there that'll be a clue.

Link to comment
Share on other sites

Where can I get this log for you?

My video drivers are up to date, and theres no option for the display adapter in the BIOS. Im gonna uninstall the video drivers and see what happens. Maybe my monitor will work too. Ill let you know when I get back.

 

EDIT 1:So I uninstalled all the video drivers, and it works. My monitor even works, though now the third HDMI monitor doesnt get detected...

Going to reinstall drivers now and see what happens. Gonna be a while, slow internet here.

 

EDIT 2: So newest drivers dont work. iCUE doesnt come up at all. Downloading older drivers now...

Edited by pjmavcom
Link to comment
Share on other sites

Im using iCue

 

EDIT: Ok its solved, but definitely not the way it shouldve been. I fresh installed Windows and everythings working. Fairly certain this wouldve worked before the update, but since I didnt have this until after, cant say for sure. Thanks for the suggestions. I still have that Windows log if that could help figuring out what Windows did, but now I see the settings page in iCUE, I know what log you were looking for. Didnt get that before I reinstalled Window though, sorry.

Edited by pjmavcom
Link to comment
Share on other sites

  • 1 month later...

Hey all, K95 and iCue have been working great until today.

Figured out what the problem was. I installed Duet Display for my iPad, reset the computer and bam, no iCue and no usb 3 monitor. Now that Ive isolated that, I was able to uninstall Duet Display and get everything back working correctly.

So, Duet Display is essentially display drivers to use the iPad as another screen and input for the computer. I guess it doesnt have OpenGL 2 with it or something as I got an error about it from iCue. Anyone have any idea about that?

Im heading to Duet Display site and looking there too. If I find something Ill post back. Thanks

Edited by pjmavcom
Link to comment
Share on other sites

 Share

×
×
  • Create New...