Jump to content
Corsair Community

Corsair C70 Front Panel Mic


bbafett
 Share

Recommended Posts

I noticed last year that when I tried to plug a headset with mic into front port of case the mic port in panel doesn't work or recognize the mic. Headphone port does recgonize fine and all USB ports work.

 

I can plug the headset into the back of the motherboard without issue in Mic/Headphone. However, everytime I want to use my speakers instead of headset I have to unplug the headset in the back and plug in speaker plug. I have checked Bios on motherboard and can't find anything that would cause it to not work. I also tried to check the wire to make sure it was plugged in properly from front panel to motherboard correctly.

 

Is it possible the case just has a bad front panel mic port or would replacing the connecting wire from case to motherboard be the issue? I would love to get this fixed so I can plug the headset into front and not have to unplug and replug every time.

 

Any thoughts?

Link to comment
Share on other sites

  • Corsair Employees

Try updating your MB audio driver and see if it'll make a difference.

 

We've seen cases where the front audio ports goes bad overtime, that's not uncommon. If you are within the case' warranty, contact our customer service and see if they can send you a front I/O replacement.

 

You can also get the part here, https://www.corsair.com/us/en/Categories/Products/Accessories-%7C-Parts/PC-Components/Cases/VENGEANCE-Series%E2%84%A2-C70-Front-I-O-Replacement-Kit/p/CC-8930077

Link to comment
Share on other sites

 Share

×
×
  • Create New...